summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2016-11-12 16:23:44 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-12 16:39:23 +0100
commit84a54f76e75c3a53d0ab2b4188bcf73c9e942518 (patch)
treebffbdb4d5a3489a08f38d01a3adf725bac8ba2af /sci-misc/boinc
parentsci-misc/boinc: Cleanup of obsolete ebuilds and files (diff)
downloadgentoo-84a54f76e75c3a53d0ab2b4188bcf73c9e942518.tar.gz
gentoo-84a54f76e75c3a53d0ab2b4188bcf73c9e942518.tar.bz2
gentoo-84a54f76e75c3a53d0ab2b4188bcf73c9e942518.zip
sci-misc/boinc: Update to EAPI 6
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2768 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/boinc-7.2.44.ebuild8
-rw-r--r--sci-misc/boinc/boinc-7.4.52.ebuild13
-rw-r--r--sci-misc/boinc/boinc-7.6.33.ebuild13
3 files changed, 25 insertions, 9 deletions
diff --git a/sci-misc/boinc/boinc-7.2.44.ebuild b/sci-misc/boinc/boinc-7.2.44.ebuild
index c36fd441b3ba..7503d03f3755 100644
--- a/sci-misc/boinc/boinc-7.2.44.ebuild
+++ b/sci-misc/boinc/boinc-7.2.44.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
WX_GTK_VER=2.8
-inherit autotools flag-o-matic linux-info systemd user versionator wxwidgets
+inherit autotools eutils linux-info systemd user versionator wxwidgets
MY_PV=$(get_version_component_range 1-2)
@@ -77,6 +77,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
# prevent bad changes in compile flags, bug 286701
sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
@@ -121,7 +123,7 @@ pkg_preinst() {
# elog user about the need of being in video group
local groups="${PN}"
if use cuda; then
- group+=",video"
+ groups+=",video"
fi
enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
}
diff --git a/sci-misc/boinc/boinc-7.4.52.ebuild b/sci-misc/boinc/boinc-7.4.52.ebuild
index 3daf627d4c98..52326a2a3e04 100644
--- a/sci-misc/boinc/boinc-7.4.52.ebuild
+++ b/sci-misc/boinc/boinc-7.4.52.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
WX_GTK_VER=3.0
-inherit autotools flag-o-matic linux-info systemd user versionator wxwidgets
+inherit autotools eutils linux-info systemd user versionator wxwidgets
MY_PV=$(get_version_component_range 1-2)
@@ -51,6 +51,11 @@ DEPEND="${RDEPEND}
app-text/docbook2X
"
+PATCHES=(
+ # >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
+ "${FILESDIR}"/fix_webview.patch
+)
+
S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
pkg_setup() {
@@ -77,6 +82,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
# prevent bad changes in compile flags, bug 286701
sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
@@ -121,7 +128,7 @@ pkg_preinst() {
# elog user about the need of being in video group
local groups="${PN}"
if use cuda; then
- group+=",video"
+ groups+=",video"
fi
enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
}
diff --git a/sci-misc/boinc/boinc-7.6.33.ebuild b/sci-misc/boinc/boinc-7.6.33.ebuild
index 3daf627d4c98..52326a2a3e04 100644
--- a/sci-misc/boinc/boinc-7.6.33.ebuild
+++ b/sci-misc/boinc/boinc-7.6.33.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
WX_GTK_VER=3.0
-inherit autotools flag-o-matic linux-info systemd user versionator wxwidgets
+inherit autotools eutils linux-info systemd user versionator wxwidgets
MY_PV=$(get_version_component_range 1-2)
@@ -51,6 +51,11 @@ DEPEND="${RDEPEND}
app-text/docbook2X
"
+PATCHES=(
+ # >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
+ "${FILESDIR}"/fix_webview.patch
+)
+
S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
pkg_setup() {
@@ -77,6 +82,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
# prevent bad changes in compile flags, bug 286701
sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
@@ -121,7 +128,7 @@ pkg_preinst() {
# elog user about the need of being in video group
local groups="${PN}"
if use cuda; then
- group+=",video"
+ groups+=",video"
fi
enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
}