summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-12-21 12:44:08 +0200
committerMart Raudsepp <leio@gentoo.org>2017-12-21 12:46:54 +0200
commit8ff0b882bc4eb16abcca916707bd2cb7d6ace4e5 (patch)
treef5cb8e571fda6a3122bb465011ea3e0d21e592b7 /sci-misc/boinc
parentsci-misc/boinc: sci-misc/boinc: bump 7.8.4 & SLOT wxGTK:3.0-gtk3 (diff)
downloadgentoo-8ff0b882bc4eb16abcca916707bd2cb7d6ace4e5.tar.gz
gentoo-8ff0b882bc4eb16abcca916707bd2cb7d6ace4e5.tar.bz2
gentoo-8ff0b882bc4eb16abcca916707bd2cb7d6ace4e5.zip
sci-misc/boinc: update icon cache in 7.8.4 as well
This brings in the iconcache update fix from 7.8.1-r1 that was pushed while 7.8.4 PR was still unmerged. But without the redundant gnome2_icon_savelist call, as the conditional to only call cache update isn't inside itself since a while now. Bug: https://bugs.gentoo.org/636886 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/boinc-7.8.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-misc/boinc/boinc-7.8.4.ebuild b/sci-misc/boinc/boinc-7.8.4.ebuild
index b29f72899783..b4628e19804e 100644
--- a/sci-misc/boinc/boinc-7.8.4.ebuild
+++ b/sci-misc/boinc/boinc-7.8.4.ebuild
@@ -5,7 +5,7 @@ EAPI=6
WX_GTK_VER=3.0-gtk3
-inherit autotools eutils linux-info systemd user versionator wxwidgets
+inherit autotools eutils gnome2-utils linux-info systemd user versionator wxwidgets
MY_PV=$(get_version_component_range 1-2)
@@ -67,7 +67,7 @@ pkg_setup() {
ewarn "Can't check the linux kernel configuration."
ewarn "You might be missing vsyscall support."
elif kernel_is -ge 4 4 \
- && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
+ && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
ewarn "You do not have vsyscall emulation enabled."
ewarn "This will prevent some boinc projects from running."
ewarn "Please enable vsyscall emulation:"
@@ -145,6 +145,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ gnome2_icon_cache_update
+
elog
elog "You are using the source compiled version of boinc."
use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
@@ -179,3 +181,7 @@ pkg_postinst() {
fi
elog
}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}