summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/espresso++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/espresso++')
-rw-r--r--sci-physics/espresso++/Manifest2
-rw-r--r--sci-physics/espresso++/espresso++-1.9.2.ebuild50
-rw-r--r--sci-physics/espresso++/espresso++-1.9.3.ebuild46
-rw-r--r--sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch65
-rw-r--r--sci-physics/espresso++/metadata.xml9
5 files changed, 172 insertions, 0 deletions
diff --git a/sci-physics/espresso++/Manifest b/sci-physics/espresso++/Manifest
new file mode 100644
index 000000000000..36c233b8d526
--- /dev/null
+++ b/sci-physics/espresso++/Manifest
@@ -0,0 +1,2 @@
+DIST espresso++-1.9.2.tar.bz2 14696734 SHA256 7bdcf502661809dc39a18b3f7fa0b0799adbf801ddb6681a197ab1bd9c7915b0 SHA512 2fffd30c24e12c079e5d3c9c98464db7add21b67e848104dc6f3952635595e4108a4d27dd5a852775cb0515e58be7a302602b34fb51dd67dff8f8677d2abb1fc WHIRLPOOL 0fe4ea6f452dd93861a3e04469b5ee8b37c55ccf4523e6ae575b99b3223f861e8e78675a3ef74ba5a3cfe3c9a039453f1eadea4fc99e339db54ac1e1304493b7
+DIST espresso++-1.9.3.tar.bz2 14714575 SHA256 602541c9e5889aeff30462f252fa5f2af7d818808ce946d11ee33500f4f2c959 SHA512 0ac90c6b09da0e7503e83cff8180373249760206fc0035b72868376abbd4a0d9121e7c92ae286493230af2080221464fc0f9428ed78101bde32eb926f07bb010 WHIRLPOOL f9fb22f4d113a47eee1d9203d4dabf5f5cef3347d7c17583459a69a6bee7392675a0f5ebab09315c4a740dba2fb412c13f3cb74ba3e8d0c99f51f62452af28e8
diff --git a/sci-physics/espresso++/espresso++-1.9.2.ebuild b/sci-physics/espresso++/espresso++-1.9.2.ebuild
new file mode 100644
index 000000000000..2e7fd3905069
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-1.9.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils multilib python-single-r1
+
+DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
+HOMEPAGE="https://www.espresso-pp.de"
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}"
+ EHG_REVISION="default"
+ inherit mercurial
+ KEYWORDS=
+else
+ inherit vcs-snapshot
+ #SRC_URI="https://espressopp.mpip-mainz.mpg.de/Download/${PN//+/p}-${PV}.tgz"
+ SRC_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ dev-python/mpi4py"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DLIB="$(get_libdir)"
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-physics/espresso++/espresso++-1.9.3.ebuild b/sci-physics/espresso++/espresso++-1.9.3.ebuild
new file mode 100644
index 000000000000..55b02857e997
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-1.9.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
+HOMEPAGE="https://www.espresso-pp.de"
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}"
+ inherit mercurial
+ KEYWORDS=
+else
+ inherit vcs-snapshot
+ #SRC_URI="https://espressopp.mpip-mainz.mpg.de/Download/${PN//+/p}-${PV}.tgz"
+ SRC_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ dev-python/mpi4py"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch b/sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch
new file mode 100644
index 000000000000..a66988b1bc82
--- /dev/null
+++ b/sci-physics/espresso++/files/espresso++-1.6.0-multilib.patch
@@ -0,0 +1,65 @@
+# HG changeset patch
+# User Christoph Junghans <christoph.junghans@gmail.com>
+# Date 1381325052 -7200
+# Node ID bcdda52214df0c007e44ec8d5045b0e68b142227
+# Parent 65da1a6110e59322efa1bb5eaff596baf9f07d5d
+added LIB variable
+
+diff -r 65da1a6110e5 -r bcdda52214df CMakeLists.txt
+--- a/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -29,6 +29,9 @@
+ option(BUILD_SHARED_LIBS "Build shared libs" ON)
+ option(BUILD_STANDALONE "Builds pypresso an standalone binary" OFF)
+ option(BUILD_PYTHON_MODULE "Builds epresso as python module" ON)
++if (NOT DEFINED LIB)
++ set(LIB "lib")
++endif(NOT DEFINED LIB)
+
+ if(NOT BUILD_STANDALONE AND NOT BUILD_PYTHON_MODULE)
+ message(FATAL_ERROR "You need to enable pypresso or the python module")
+diff -r 65da1a6110e5 -r bcdda52214df contrib/boost/CMakeLists.txt
+--- a/contrib/boost/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/contrib/boost/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -21,4 +21,4 @@
+
+ add_library(espresso_boost ${BOOST_SOURCES})
+ target_link_libraries(espresso_boost ${PYTHON_LIBRARIES} ${VAMPIRTRACE_LIBRARIES} ${MPI_LIBRARIES} ${RT_LIBRARIES})
+-install(TARGETS espresso_boost LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
++install(TARGETS espresso_boost LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION lib)
+diff -r 65da1a6110e5 -r bcdda52214df contrib/mpi4py/CMakeLists.txt
+--- a/contrib/mpi4py/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/contrib/mpi4py/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -12,4 +12,4 @@
+ target_link_libraries(dl ${PYTHON_LIBRARIES} ${VAMPIRTRACE_LIBRARIES} ${MPI_LIBRARIES})
+ set_target_properties(dl PROPERTIES PREFIX "" SUFFIX ".so")
+
+-install(TARGETS MPI LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION lib)
++install(TARGETS MPI LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${LIB})
+diff -r 65da1a6110e5 -r bcdda52214df src/CMakeLists.txt
+--- a/src/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/src/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -70,11 +70,11 @@
+ add_library(espresso_common ${ESPRESSO_SOURCES})
+ target_link_libraries(espresso_common pylogger ${BOOST} ${PYTHON_LIBRARIES}
+ ${VAMPIRTRACE_LIBRARIES} ${MPI_LIBRARIES} ${FFTW3_LIBRARIES})
+-install(TARGETS espresso_common LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
++install(TARGETS espresso_common LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION lib)
+
+ add_library(pylogger esutil/PyLogger.cpp)
+ target_link_libraries(pylogger ${BOOST})
+-install(TARGETS pylogger LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
++install(TARGETS pylogger LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION lib)
+
+ if(BUILD_STANDALONE)
+ add_executable(pypresso main/pypresso.cpp)
+diff -r 65da1a6110e5 -r bcdda52214df src/pymodule/CMakeLists.txt
+--- a/src/pymodule/CMakeLists.txt Tue Oct 08 20:52:46 2013 +0200
++++ b/src/pymodule/CMakeLists.txt Wed Oct 09 15:24:12 2013 +0200
+@@ -5,5 +5,5 @@
+ add_dependencies(_espresso scripts)
+ #python libs have not prefix (default would be 'lib')
+ set_target_properties(_espresso PROPERTIES PREFIX "" SUFFIX ".so")
+- install(TARGETS _espresso LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION lib)
++ install(TARGETS _espresso LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${LIB})
+ endif(BUILD_PYTHON_MODULE)
diff --git a/sci-physics/espresso++/metadata.xml b/sci-physics/espresso++/metadata.xml
new file mode 100644
index 000000000000..ee9feacef4f8
--- /dev/null
+++ b/sci-physics/espresso++/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+</pkgmetadata>