summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-11-04 16:43:20 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-06 17:12:18 +0100
commitef27371a29517e3676d514d3bf731f7288e96c90 (patch)
tree4ff72d408ec719e90a3f42714ca8a56a00070341 /sci-physics/rivet
parentdev-python/louie: amd64 stable (diff)
downloadgentoo-ef27371a29517e3676d514d3bf731f7288e96c90.tar.gz
gentoo-ef27371a29517e3676d514d3bf731f7288e96c90.tar.bz2
gentoo-ef27371a29517e3676d514d3bf731f7288e96c90.zip
sci-physics/rivet: Version bump to 2.5.2, EAPI bump 5 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2740 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics/rivet')
-rw-r--r--sci-physics/rivet/Manifest2
-rw-r--r--sci-physics/rivet/rivet-2.5.2.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/sci-physics/rivet/Manifest b/sci-physics/rivet/Manifest
index 6057c85a3211..d184eee58c3d 100644
--- a/sci-physics/rivet/Manifest
+++ b/sci-physics/rivet/Manifest
@@ -1 +1,3 @@
DIST Rivet-2.3.0.tar.bz2 2742948 SHA256 dd07702981d586e4b97b0fa56ae08cd08a631a952322a9b52e7622a46a7741ab SHA512 b51b77f80d69156dead899312cad838bc03479a072e163df50262e86790503515f8ab8af93723c3cbd33007d9812aa10581b2c960d92bc1fcf5031d27018d239 WHIRLPOOL ce9e5dd34ba9b53de192aee39bcd94565a62a328bd35dcb1ef810cc7b129e9ae6529fc8f970889f7a6970567bdd0f040d15fc5bbb83ec22e38daccb34cbb4fdf
+DIST Rivet-2.5.2.tar.bz2 3005023 SHA256 70aa27764a14159c94c0b753a0c3d3600ac669def398cb2d8a6c63ae17704f05 SHA512 dd84143eb5d4b24ae2e5ace175e349fe48b4b5e6a47b3aa031a4144c635f016e8bbd731ed3f96b5c2f52c7df8ff0f1db70750fc45381bdfcdd469fd4c058beef WHIRLPOOL cd17c53ba337cc5f6e9d747f37640b86958844cfbf328a99350a3e7850e1ae158aab6cbedd8791da3f5f56084ed219a8ff7d9b2bc3d9c73848531f0d868c475a
+DIST refs.bib 65375 SHA256 c4c0a1d1d46c504baff9f44fdb9ecec5adc7773c89746e9b573abd2349c61431 SHA512 ab6c0942235f4f88de0c3801c0be4b0e51643a684c6cf55ae58db57a5ffa0e59c9a616547f8a7549b696888983ac3980f1f0d1bfd21adbfbfa732e12ee2e5ce2 WHIRLPOOL c2e31e4a4159f101ecc094d33e65321ce5aa7aa2e1e30f56c8fd34d5f7a22f581f2a269478e30066c8ad03a50279c1b7cf7db8b357f446646fcab8a54e8d8d99
diff --git a/sci-physics/rivet/rivet-2.5.2.ebuild b/sci-physics/rivet/rivet-2.5.2.ebuild
new file mode 100644
index 000000000000..7e55cc4285e2
--- /dev/null
+++ b/sci-physics/rivet/rivet-2.5.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools bash-completion-r1 python-single-r1
+
+DESCRIPTION="Toolkit for validation of Monte Carlo HEP event generators"
+HOMEPAGE="http://rivet.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${P^}.tar.bz2
+ doc? ( https://rivet.hepforge.org/trac/browser/doc/refs.bib )"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/boost:=
+ sci-libs/gsl:=
+ sci-physics/fastjet[plugins]
+ sci-physics/hepmc
+ >=sci-physics/yoda-1.5.0[python]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex,dot] )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ unpack "${P^}.tar.bz2"
+
+ if use doc; then
+ # refs.bib is missing in tarball (reported upstream)
+ cp "${DISTDIR}"/refs.bib "${S}"/doc || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Install rivet-manual.pdf to docdir intead of pkgdatadir
+ sed -i '/pkgdata_DATA = $(DOCS)/s/pkgdata/doc/' doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python pyext) \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable doc pdfmanual)
+}
+
+src_compile() {
+ use doc && export VARTEXFONTS="${T}/fonts"
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die
+ HTML_DOCS+=( doxy/html/. )
+ fi
+}
+
+src_install() {
+ default
+
+ newbashcomp "${ED%/}"/usr/share/Rivet/rivet-completion rivet
+ rm -f "${ED%/}"/usr/share/Rivet/rivet-completion || die
+}