summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-10-15 01:03:09 -0400
committerGuilherme Amadio <amadio@gentoo.org>2017-10-16 11:44:54 +0200
commitec1223124a8d0d3065019c40d69c7675b801a8fb (patch)
treebce3a8941c33d2f22a4e308ea7a9949d0f64ea3a /sci-physics/thepeg
parentmedia-video/smtube: correct smplayer dependency (diff)
downloadgentoo-ec1223124a8d0d3065019c40d69c7675b801a8fb.tar.gz
gentoo-ec1223124a8d0d3065019c40d69c7675b801a8fb.tar.bz2
gentoo-ec1223124a8d0d3065019c40d69c7675b801a8fb.zip
sci-physics/thepeg: Fix building with GCC-6
Bug: https://bugs.gentoo.org/599564 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'sci-physics/thepeg')
-rw-r--r--sci-physics/thepeg/files/thepeg-2.0.4-gcc6.patch14
-rw-r--r--sci-physics/thepeg/thepeg-2.0.4.ebuild7
2 files changed, 19 insertions, 2 deletions
diff --git a/sci-physics/thepeg/files/thepeg-2.0.4-gcc6.patch b/sci-physics/thepeg/files/thepeg-2.0.4-gcc6.patch
new file mode 100644
index 000000000000..ed3bdac7b54b
--- /dev/null
+++ b/sci-physics/thepeg/files/thepeg-2.0.4-gcc6.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/599564
+
+--- a/Utilities/UnitIO.h
++++ b/Utilities/UnitIO.h
+@@ -25,6 +25,9 @@
+
+ namespace ThePEG {
+
++using std::isnan;
++using std::isinf;
++
+ /**
+ * The OUnit< class is used to
+ * facilitate output of unitful numbers to a
diff --git a/sci-physics/thepeg/thepeg-2.0.4.ebuild b/sci-physics/thepeg/thepeg-2.0.4.ebuild
index 84e48567e16a..6cea3900306d 100644
--- a/sci-physics/thepeg/thepeg-2.0.4.ebuild
+++ b/sci-physics/thepeg/thepeg-2.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,7 +37,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${PN}-1.8.3-java.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.3-java.patch
+ "${FILESDIR}"/${PN}-2.0.4-gcc6.patch
+)
src_prepare() {
find -name 'Makefile.am' -exec \