summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-08 19:55:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-08 19:59:37 +0200
commit1ea6b27ef3cf489d099d3753b5c8c2050d67054e (patch)
treecbcca0db79ed84b5f69f11017c0995c8a06e92a6 /sci-visualization
parentwww-client/chromium: dev channel bump (59.0.3063.4) (diff)
downloadgentoo-1ea6b27ef3cf489d099d3753b5c8c2050d67054e.tar.gz
gentoo-1ea6b27ef3cf489d099d3753b5c8c2050d67054e.tar.bz2
gentoo-1ea6b27ef3cf489d099d3753b5c8c2050d67054e.zip
sci-visualization/labplot: 2.4.0 version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/labplot/Manifest1
-rw-r--r--sci-visualization/labplot/labplot-2.4.0.ebuild73
-rw-r--r--sci-visualization/labplot/labplot-9999.ebuild6
3 files changed, 77 insertions, 3 deletions
diff --git a/sci-visualization/labplot/Manifest b/sci-visualization/labplot/Manifest
index 689f27edbda8..a2b212d933cc 100644
--- a/sci-visualization/labplot/Manifest
+++ b/sci-visualization/labplot/Manifest
@@ -1 +1,2 @@
DIST labplot-2.3.0-kf5.tar.xz 4531156 SHA256 a5a7d706de5f978430b359ada42f9227a2619f5fa9608d56af16c760b7626f33 SHA512 0f8053bfccbfb6756db14c2d35f69b18bc83395c15cc01cbe61e5877065ad587e1563e7f161dfbac7c75b8b30aa04ee112e0c1962b52544e33ca936bd17b1444 WHIRLPOOL febd50c0a36612a1f93d8190eb9907ede4c29513652cc1a99cfc196c464eb7a7d6bc8692e13a98a9ce31e963a15396385dd9d7b015fe65bd995e2b85e9a09f94
+DIST labplot-2.4.0-kf5.tar.xz 6038072 SHA256 86198247ff0d274c85607cdb07a0c4ef19149e4f4bf6c9d2e6e8249134e26bb2 SHA512 5d29dd7d63d484359e73c8d82d8dbc25a069e1f33829cf75c2a2009ebae2027353ecf578b51806b5f35ae17ec472f5cbfdb4caed2637dc1ecc9229d33033d21b WHIRLPOOL 8d5af85ae52bbe1526d00888c1a18922a0f27c3dbf4ff992736e6672008ca61f54f8df93a1c0185bf4fcdcebe4543e58aa7260eafaf40ba8abf87b39ab84bad4
diff --git a/sci-visualization/labplot/labplot-2.4.0.ebuild b/sci-visualization/labplot/labplot-2.4.0.ebuild
new file mode 100644
index 000000000000..41c5faefd1e7
--- /dev/null
+++ b/sci-visualization/labplot/labplot-2.4.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_BRANCH="frameworks"
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Scientific data analysis and visualisation based on KDE Frameworks"
+HOMEPAGE="https://www.kde.org/applications/education/labplot/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}-kf5.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="cantor fftw fits hdf5 netcdf"
+
+[[ ${KDE_BUILD_TYPE} != live ]] && S="${WORKDIR}/${P}-kf5"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ >=sci-libs/gsl-1.15:=
+ cantor? ( $(add_kdeapps_dep cantor) )
+ fftw? ( sci-libs/fftw:3.0= )
+ fits? ( sci-libs/cfitsio:= )
+ hdf5? ( sci-libs/hdf5:= )
+ netcdf? ( sci-libs/netcdf:= )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ x11-misc/shared-mime-info
+"
+RDEPEND="${COMMON_DEPEND}
+ !sci-visualization/labplot:4
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook && [[ ${KDE_BUILD_TYPE} != live ]]; then
+ cmake_comment_add_subdirectory doc-translations
+ fi
+
+ punt_bogus_dep KF5 NewStuff
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CANTOR=$(usex cantor)
+ -DENABLE_FFTW=$(usex fftw)
+ -DENABLE_FITS=$(usex fits)
+ -DENABLE_HDF5=$(usex hdf5)
+ -DENABLE_NETCDF=$(usex netcdf)
+ )
+
+ kde5_src_configure
+}
diff --git a/sci-visualization/labplot/labplot-9999.ebuild b/sci-visualization/labplot/labplot-9999.ebuild
index 463b7dba15eb..6eebaf152481 100644
--- a/sci-visualization/labplot/labplot-9999.ebuild
+++ b/sci-visualization/labplot/labplot-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -52,11 +52,11 @@ RDEPEND="${COMMON_DEPEND}
"
src_prepare() {
+ kde5_src_prepare
+
if ! use handbook && [[ ${KDE_BUILD_TYPE} != live ]]; then
cmake_comment_add_subdirectory doc-translations
fi
-
- kde5_src_prepare
}
src_configure() {