summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-03 12:45:25 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-03 13:05:59 +0200
commit5ac6071c931acd281eddd9bae478386df7a1bfc3 (patch)
tree37362aa0ff33242e84a48dacb43d56f36f279933 /sys-apps/baselayout
parentsys-apps/baselayout: Fix SYMLINK_LIB=no to create lib dir instead of sym (diff)
downloadgentoo-5ac6071c931acd281eddd9bae478386df7a1bfc3.tar.gz
gentoo-5ac6071c931acd281eddd9bae478386df7a1bfc3.tar.bz2
gentoo-5ac6071c931acd281eddd9bae478386df7a1bfc3.zip
sys-apps/baselayout: Do not complain about lib+lib32 when it is valid
Remove the error on 'lib' directory with SYMLINK_LIB=no multilib layout if lib32 is a valid directory as well. This fixes the wrong assert in the new no-lib-symlink profile while preserving the check on regular lib+lib64 profile.
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-2.3.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-apps/baselayout/baselayout-2.3.ebuild b/sys-apps/baselayout/baselayout-2.3.ebuild
index b4e82d224cdd..d3d135162a91 100644
--- a/sys-apps/baselayout/baselayout-2.3.ebuild
+++ b/sys-apps/baselayout/baselayout-2.3.ebuild
@@ -87,7 +87,7 @@ multilib_layout() {
else
mkdir -p "${prefix}lib" || die
fi
- elif [ -d "${prefix}lib" ] ; then
+ elif [ -d "${prefix}lib" ] && ! has lib32 ${libdirs} ; then
# make sure the old "lib" ABI location does not exist; we
# only symlinked the lib dir on systems where we moved it
# to "lib32" ...