summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-28 10:41:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-28 10:41:25 -0500
commitdc532af68af60edcea27ad67dcf5956e9e65075b (patch)
tree7b2ede376cc11e29970697fca83b633ca0f8a17e /sys-apps/bolt/bolt-0.4.ebuild
parentnet-vpn/i2pd: remove old (diff)
downloadgentoo-dc532af68af60edcea27ad67dcf5956e9e65075b.tar.gz
gentoo-dc532af68af60edcea27ad67dcf5956e9e65075b.tar.bz2
gentoo-dc532af68af60edcea27ad67dcf5956e9e65075b.zip
sys-apps/bolt: initial add of the daemon
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps/bolt/bolt-0.4.ebuild')
-rw-r--r--sys-apps/bolt/bolt-0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/bolt/bolt-0.4.ebuild b/sys-apps/bolt/bolt-0.4.ebuild
new file mode 100644
index 000000000000..43fd351f9483
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3."
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0:2
+ virtual/libudev
+ virtual/udev
+ sys-auth/polkit[introspection]
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ keepdir /var/lib/boltd
+}