summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-10 21:12:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-10 21:12:16 -0500
commit98f811b950b1f401f1065a9c577194f16afdaaf7 (patch)
tree974edd50abce3a3882e1c6503e29bed327e2a25b /sys-apps/bolt
parentwww-client/firefox: adjust rust version requirement (diff)
downloadgentoo-98f811b950b1f401f1065a9c577194f16afdaaf7.tar.gz
gentoo-98f811b950b1f401f1065a9c577194f16afdaaf7.tar.bz2
gentoo-98f811b950b1f401f1065a9c577194f16afdaaf7.zip
sys-apps/bolt: 0.8 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-apps/bolt')
-rw-r--r--sys-apps/bolt/Manifest1
-rw-r--r--sys-apps/bolt/bolt-0.8.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index 2bed76013362..fb8489437a95 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -1,3 +1,4 @@
DIST bolt-0.4.tar.gz 113525 BLAKE2B 4d6b25b60a35bbeee724e4549a49709ff19d99457c8a35c02c66026cdca999359220d09812f8e9f44586b5e3cf3dda2e3ff30f35a4f37ed6d815535e62af39f3 SHA512 3ea6b748768b5d9df60425274ecdb4ccd5ce6599e01f0648a24704643fbbadd7a114d4a1946ee3b7bd8866935758cbfe4494734c26c12ccc508c205a036d5317
DIST bolt-0.5.tar.gz 149665 BLAKE2B ca7f937d4b7f4911cba93f8619e52af37f18a6542bc76aaee388a9122ea38d11ba0a21f4afb45bd6109e12ada4662783cb8f7aebec0d58751ace6c18c49ace88 SHA512 d36f2e39ac53b131fb9607055231a5a205c368547c0db2c3a7537b6e60b156c8b0663d1e5b09c825e1e1a63fbe21087746d0bafde1bd474eb90f1d0cff991246
DIST bolt-0.7.tar.gz 188158 BLAKE2B c51588ed746fd2aef15c79c278efe73e78ed8a029d2234b7a6ce717a6a3287ad0e9db82f93661c552a6a35c76a0e16a2712681f45e53f876b3b4f5bd839005b3 SHA512 6786f701501cc2680fac52cda7cdfe37971044abcf058b5c83bfa9f1d0a0381ba00e3377cfc97fcccf53760a2eafc1f8f6d0754f0e121d94201711ad8e40a135
+DIST bolt-0.8.tar.gz 219317 BLAKE2B 9d76f3630d7f690c96447a894e54095deb7a19e46f2b02d7fbd9e584376d6b1a19391007a3a80e293adc8c9de6470279b587807d08006bbc12c7179bf0501e40 SHA512 0fdbc026178a4ca6a8c53aa46933d1c411eb04e350955f8b10c7faff814576d0796dd28e56b968648e549c79cf5fa13d43970d797595af0f66457abaef8ace09
diff --git a/sys-apps/bolt/bolt-0.8.ebuild b/sys-apps/bolt/bolt-0.8.ebuild
new file mode 100644
index 000000000000..28823c01d33e
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3."
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0:2
+ dev-util/glib-utils
+ virtual/libudev
+ virtual/udev
+ dev-util/umockdev
+ sys-auth/polkit[introspection]
+ systemd? ( sys-apps/systemd:0= )
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ -Dsystemd=$(usex systemd true false)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ keepdir /var/lib/boltd
+}