summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-06-22 20:51:43 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-06-22 20:51:43 +0300
commit38d5709547d294cbbff427237798cc08f08062f6 (patch)
tree5fd7cfbe101b30de75bfe2486f723629183ee8f3 /sys-apps/file
parentsys-apps/file: mark stable wrt bug #657930 (diff)
downloadgentoo-38d5709547d294cbbff427237798cc08f08062f6.tar.gz
gentoo-38d5709547d294cbbff427237798cc08f08062f6.tar.bz2
gentoo-38d5709547d294cbbff427237798cc08f08062f6.zip
sys-apps/file: Drop old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest1
-rw-r--r--sys-apps/file/file-5.32-r1.ebuild124
-rw-r--r--sys-apps/file/file-5.33-r1.ebuild125
3 files changed, 0 insertions, 250 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index e5fb79cb1b2b..25da8f481e0e 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -1,2 +1 @@
-DIST file-5.32.tar.gz 797025 BLAKE2B d00196a2331b7325acc1b3f52d011faa3864db526f1962e4fcb769a92a715a1ee9874750cdde8f7c5c48541ecedea36c0fbd788a5ee9eb175cfcfc984acec430 SHA512 315343229fa196335389544ee8010e9e80995ef4721938492dedcfb0465dfc45e1feb96f26dfe53cab484fb5d9bac54d2d72917fbfd28a1d998c6ad8c8f9792f
DIST file-5.33.tar.gz 817060 BLAKE2B 735f176f09085243dacaddda1b734ef2191ff1684f08022ed1874e84fd0c84679b5a765383c5c5ad27a7216abc23b9c2211fb7110846122563e18285de0f0e51 SHA512 36c9f2e2aa814b5557eef114fdd3de159688c7a3c9632a9f5c6355c4d2a5694cee81279bda80897616fca07289a7fedb1f797439a2903c76dc84870694773c9e
diff --git a/sys-apps/file/file-5.32-r1.ebuild b/sys-apps/file/file-5.32-r1.ebuild
deleted file mode 100644
index 389e0e1c2d7f..000000000000
--- a/sys-apps/file/file-5.32-r1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 libtool ltprune toolchain-funcs multilib-minimal
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/glensc/file.git"
- inherit autotools git-r3
-else
- SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="https://www.darwinsys.com/file/"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="python static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
-RDEPEND="${DEPEND}
- python? ( !dev-python/python-magic )"
-
-src_prepare() {
- default
-
- [[ ${PV} == "9999" ]] && eautoreconf
- elibtoolize
-
- # don't let python README kill main README #60043
- mv python/README{,.python} || die
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --enable-fsect-man5
- $(use_enable static-libs static)
- $(use_enable zlib)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-src_configure() {
- # when cross-compiling, we need to build up our own file
- # because people often don't keep matching host/target
- # file versions #362941
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- mkdir -p "${WORKDIR}"/build || die
- cd "${WORKDIR}"/build || die
- tc-export_build_env BUILD_C{C,XX}
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=no \
- ac_cv_lib_z_gzopen=no \
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- CC=${BUILD_CC} \
- CXX=${BUILD_CXX} \
- econf --disable-shared
- fi
-
- multilib-minimal_src_configure
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi ; then
- emake
- else
- cd src || die
- emake magic.h #586444
- emake libmagic.la
- fi
-}
-
-src_compile() {
- if tc-is-cross-compiler && ! ROOT=/ has_version "~${CATEGORY}/${P}" ; then
- emake -C "${WORKDIR}"/build/src magic.h #586444
- emake -C "${WORKDIR}"/build/src file
- PATH="${WORKDIR}/build/src:${PATH}"
- fi
- multilib-minimal_src_compile
-
- if use python ; then
- cd python || die
- distutils-r1_src_compile
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi ; then
- default
- else
- emake -C src install-{nodist_includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
- fi
-}
-
-multilib_src_install_all() {
- dodoc ChangeLog MAINT README
-
- # Required for `file -C`
- dodir /usr/share/misc/magic
- insinto /usr/share/misc/magic
- doins -r magic/Magdir/*
-
- if use python ; then
- cd python || die
- distutils-r1_src_install
- fi
- prune_libtool_files
-}
diff --git a/sys-apps/file/file-5.33-r1.ebuild b/sys-apps/file/file-5.33-r1.ebuild
deleted file mode 100644
index ffec3650582f..000000000000
--- a/sys-apps/file/file-5.33-r1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1 libtool ltprune toolchain-funcs multilib-minimal
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/glensc/file.git"
- inherit autotools git-r3
-else
- SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="https://www.darwinsys.com/file/"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="python static-libs zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
-RDEPEND="${DEPEND}
- python? ( !dev-python/python-magic )"
-
-src_prepare() {
- default
-
- [[ ${PV} == "9999" ]] && eautoreconf
- elibtoolize
-
- # don't let python README kill main README #60043
- mv python/README{,.python} || die
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-libseccomp
- --enable-fsect-man5
- $(use_enable static-libs static)
- $(use_enable zlib)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-src_configure() {
- # when cross-compiling, we need to build up our own file
- # because people often don't keep matching host/target
- # file versions #362941
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- mkdir -p "${WORKDIR}"/build || die
- cd "${WORKDIR}"/build || die
- tc-export_build_env BUILD_C{C,XX}
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=no \
- ac_cv_lib_z_gzopen=no \
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- CC=${BUILD_CC} \
- CXX=${BUILD_CXX} \
- econf --disable-shared --disable-libseccomp
- fi
-
- multilib-minimal_src_configure
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi ; then
- emake
- else
- cd src || die
- emake magic.h #586444
- emake libmagic.la
- fi
-}
-
-src_compile() {
- if tc-is-cross-compiler && ! ROOT=/ has_version "~${CATEGORY}/${P}" ; then
- emake -C "${WORKDIR}"/build/src magic.h #586444
- emake -C "${WORKDIR}"/build/src file
- PATH="${WORKDIR}/build/src:${PATH}"
- fi
- multilib-minimal_src_compile
-
- if use python ; then
- cd python || die
- distutils-r1_src_compile
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi ; then
- default
- else
- emake -C src install-{nodist_includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
- fi
-}
-
-multilib_src_install_all() {
- dodoc ChangeLog MAINT README
-
- # Required for `file -C`
- dodir /usr/share/misc/magic
- insinto /usr/share/misc/magic
- doins -r magic/Magdir/*
-
- if use python ; then
- cd python || die
- distutils-r1_src_install
- fi
- prune_libtool_files
-}