summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-09 23:50:22 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-09 23:57:14 -0500
commit8982707c75ff1e6bbcdd835d835b578905114099 (patch)
tree9d34d2f3195a55362c2842e780e3fe2e298da63b /sys-apps/gentoo-functions
parentnet-mail/offlineimap: version bump to 7.0.9 (diff)
downloadgentoo-8982707c75ff1e6bbcdd835d835b578905114099.tar.gz
gentoo-8982707c75ff1e6bbcdd835d835b578905114099.tar.bz2
gentoo-8982707c75ff1e6bbcdd835d835b578905114099.zip
sys-apps/gentoo-functions: fix source errors w/dumb terminals
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/Manifest1
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.11.ebuild30
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild9
3 files changed, 35 insertions, 5 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index 3a1aea6d8119..b258e7a7661d 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1 +1,2 @@
DIST gentoo-functions-0.10.tar.gz 11432 SHA256 709c8b22f404001a512e47a7a4d3192070b3e150fb9d0f943de09736d665b0db SHA512 2622cede032089c7b8a2dec576e848852f9964e0198ab161f0ff5c426c542d0849bd3d30a40c296805bfec90b533c419df43c7975ed85678471483c827ca4cdb WHIRLPOOL 6559c62083eca8a016f005d1003c8a0b6e2c89836c130cec9e0a40575e1604039f669313547c63f6cf84f1a40cdd7249d227c6f0b57f282764df8d20ef239051
+DIST gentoo-functions-0.11.tar.gz 11511 SHA256 e861e1fc4da45c07c62889d80e9d2d869ef92bba4f96d1b41aff119c3e9c8099 SHA512 eb9a0ee72c31ca18b6b71e08223b3c0ba822333f051947579e4f66b26082c5e6fc91c2da34967cf9fed9e2b5143690e0e1166282c26d122c5aaa24848b8418a3 WHIRLPOOL 37185f024b67ac0ba40ff5aff44e054f1b6ce4f657834d6f06bc95ccd3a3d8f74bc9faae54d1f386dfbb41e54e655f3023fda064cc3b30243ed58029765c024f
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.11.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.11.ebuild
new file mode 100644
index 000000000000..452d8d7fb4d1
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+ append-lfs-flags
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+}
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index d22ee7f391cd..452d8d7fb4d1 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
+EAPI="5"
-if [[ ${PV} = 9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
else
@@ -14,7 +13,7 @@ fi
inherit toolchain-funcs flag-o-matic
-DESCRIPTION="base functions required by all gentoo systems"
+DESCRIPTION="base functions required by all Gentoo systems"
HOMEPAGE="https://www.gentoo.org"
LICENSE="GPL-2"