summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-28 21:55:00 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-28 22:29:21 +0200
commit1f0f3b4f094193ff5972ebc82fcabf3718ff007e (patch)
tree4bebc530c08e49c5fbced1d7d3b8ed744c15dc62 /sys-apps/gnome-disk-utility
parentx11-libs/libwnck: Version bump (diff)
downloadgentoo-1f0f3b4f094193ff5972ebc82fcabf3718ff007e.tar.gz
gentoo-1f0f3b4f094193ff5972ebc82fcabf3718ff007e.tar.bz2
gentoo-1f0f3b4f094193ff5972ebc82fcabf3718ff007e.zip
sys-apps/gnome-disk-utility: Drop old
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-apps/gnome-disk-utility')
-rw-r--r--sys-apps/gnome-disk-utility/Manifest2
-rw-r--r--sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch46
-rw-r--r--sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch35
-rw-r--r--sys-apps/gnome-disk-utility/gnome-disk-utility-3.16.2.ebuild56
-rw-r--r--sys-apps/gnome-disk-utility/gnome-disk-utility-3.18.2.ebuild47
5 files changed, 0 insertions, 186 deletions
diff --git a/sys-apps/gnome-disk-utility/Manifest b/sys-apps/gnome-disk-utility/Manifest
index ff1cce08363d..4f72019a05b9 100644
--- a/sys-apps/gnome-disk-utility/Manifest
+++ b/sys-apps/gnome-disk-utility/Manifest
@@ -1,3 +1 @@
-DIST gnome-disk-utility-3.16.2.tar.xz 1432332 SHA256 4a495563a0142d2a64d9f573e5333a82d6c3c94ab5c8cd9b1878bfa36ae15353 SHA512 228187c1f3354c3a11dda3d4b85abed3e54bb7e5f105971f5d39f72fa52bcc9b44344c27148c604b2a87ed83942724187af90527e48acb9e9bc888922c34a53b WHIRLPOOL ef0b1b6f2cbeac1533798854796905909b866f45f9377bbd05060df1f615d81e0cb58a2e9d8bfbf3b9bef3d22d24cba45ec8d64ddbe63887bbbce75967ca1969
-DIST gnome-disk-utility-3.18.2.tar.xz 1465016 SHA256 2fbe46349256829641f8b1ecdf299f9c32ebe35a7055448e36a61da31f0bcebf SHA512 2260185522659a0f0010cf9295b29362402101057c5f1afddf48ba10a0ab82e0798a2f478eb2e82887c73f7ce5c3f67a297c9a6af266cf137eb119b929f1f33d WHIRLPOOL 6dd8dd2b3a033bbff36315c1323ad5ca13e09ea0ca253fdc34312e09d07b27cf00fc8f856ac27b98c6b49fe9635670229a54a29c802d3d1b2b4bfa56eb273301
DIST gnome-disk-utility-3.18.3.1.tar.xz 1465472 SHA256 652e6332bcf987b15621ebcefc2c14f360b21b7295f94fded6ecfc40c45ae4e8 SHA512 3f8507cc07bc88a8cd7e3415310c27edfb0cb3887dc5aa0f765beced1df12de43c09c0daeb9cc17b4d81c597941b25cfc9b9859ad3577459ad055702299860ba WHIRLPOOL 43a83149ee2db9fd5909294acb5179cc683e35416a05a521d9d77460fdbf21d315ae15367c7dd8bcfbdbcb8d3c9aa8a5fdb1d7cdfbf0a29ddb4c4d8872399ced
diff --git a/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch
deleted file mode 100644
index c6d414c0ae97..000000000000
--- a/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From cfefd62c7f23625fd1b07dacb35681bdf5aafa04 Mon Sep 17 00:00:00 2001
-From: Andreas Henriksson <andreas@fatal.se>
-Date: Fri, 5 Apr 2013 12:42:06 +0200
-Subject: [PATCH 1/2] Avoid needing gsd during build when --disable-gsd-plugin
- is used
-
-PKG_CHECK_MODULES was previously unconditionally requiring
-gnome-settings-daemon to be available, even when it was later
-not going to be used because the --disable-gsd-plugin configure
-switch was passed.
-
-Move the check to only require g-s-d when it's actually going to be
-used.
-
-While at it, also fix the indentation of the msg_gsd_plugin=yes line.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=697146
----
- configure.ac | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index cce9d62..d8f6198 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -120,7 +120,6 @@ PKG_CHECK_MODULES(LIBSECRET1, [libsecret-1 >= $LIBSECRET1_REQUIRED])
- PKG_CHECK_MODULES(PWQUALITY, [pwquality >= $PWQUALITY_REQUIRED])
- PKG_CHECK_MODULES(CANBERRA, [libcanberra-gtk3 >= $CANBERRA_REQUIRED])
- PKG_CHECK_MODULES(LIBDVDREAD, [dvdread >= $LIBDVDREAD_REQUIRED])
--PKG_CHECK_MODULES(GSD_PLUGIN, [gnome-settings-daemon >= $GSD_PLUGIN_REQUIRED])
- PKG_CHECK_MODULES(LIBNOTIFY, [libnotify >= $LIBNOTIFY_REQUIRED])
- PKG_CHECK_MODULES(LIBLZMA, [liblzma >= $LIBLZMA_REQUIRED])
-
-@@ -157,7 +156,8 @@ dnl *************************************
- AC_ARG_ENABLE(gsd_plugin, AS_HELP_STRING([--disable-gsd-plugin],[don't build gnome-settings-daemon plug-in]))
- msg_gsd_plugin=no
- if test "x$enable_gsd_plugin" != "xno"; then
-- msg_gsd_plugin=yes
-+ msg_gsd_plugin=yes
-+ PKG_CHECK_MODULES(GSD_PLUGIN, [gnome-settings-daemon >= $GSD_PLUGIN_REQUIRED])
- fi
- AM_CONDITIONAL(USE_GSD_PLUGIN, [test "$msg_gsd_plugin" = "yes"])
-
---
-1.8.3.2
-
diff --git a/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch
deleted file mode 100644
index f5ff3cec5359..000000000000
--- a/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From f05af64dd29a5119f36d0c34f0d6aa9f04567933 Mon Sep 17 00:00:00 2001
-From: Andreas Henriksson <andreas@fatal.se>
-Date: Fri, 5 Apr 2013 12:30:55 +0200
-Subject: [PATCH 2/2] Bump required version of gnome-settings-daemon to 3.8
-
-Reported by Pacho Ramos in https://bugzilla.gnome.org/697146
-and from the references gentoo bug report:
-
-With gnome-base/gnome-settings-daemon-3.6.4:
-
-gdusdmanager.c: At top level:
-gdusdmanager.c:42:1: error: unknown type name 'GduSdClass'
-gdusdmanager.c:80:1: warning: 'gdu_sd_manager_start' defined but not used [-Wunused-function]
-gdusdmanager.c:124:1: warning: 'gdu_sd_manager_new' defined but not used [-Wunused-function]
-make[3]: *** [libgdu_sd_la-gdusdmanager.lo] Error 1
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index d8f6198..2604798 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -109,7 +109,7 @@ LIBSECRET1_REQUIRED=0.7
- PWQUALITY_REQUIRED=1.0.0
- CANBERRA_REQUIRED=0.1
- LIBDVDREAD_REQUIRED=4.2.0
--GSD_PLUGIN_REQUIRED=3.6
-+GSD_PLUGIN_REQUIRED=3.8
- LIBNOTIFY_REQUIRED=0.7
- LIBLZMA_REQUIRED=5.0.5
-
---
-1.8.3.2
-
diff --git a/sys-apps/gnome-disk-utility/gnome-disk-utility-3.16.2.ebuild b/sys-apps/gnome-disk-utility/gnome-disk-utility-3.16.2.ebuild
deleted file mode 100644
index d88a0a0729dc..000000000000
--- a/sys-apps/gnome-disk-utility/gnome-disk-utility-3.16.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools eutils gnome2
-
-DESCRIPTION="Disk Utility for GNOME using udisks"
-HOMEPAGE="https://git.gnome.org/browse/gnome-disk-utility"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="fat +gnome systemd"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.31:2
- >=sys-fs/udisks-2.1.1:2
- >=x11-libs/gtk+-3.12:3
- >=app-arch/xz-utils-5.0.5
- >=app-crypt/libsecret-0.7
- dev-libs/libpwquality
- systemd? ( >=sys-apps/systemd-44:0= )
-"
-RDEPEND="${COMMON_DEPEND}
- >=media-libs/libdvdread-4.2.0
- >=media-libs/libcanberra-0.1[gtk3]
- >=x11-libs/libnotify-0.7:=
- >=x11-themes/gnome-icon-theme-symbolic-2.91
- fat? ( sys-fs/dosfstools )
- gnome? ( >=gnome-base/gnome-settings-daemon-3.8 )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.50
- dev-libs/libxslt
- gnome-base/gnome-common
- virtual/pkgconfig
-"
-
-src_prepare() {
- # Fix USE=-gnome, bug #478820
- epatch "${FILESDIR}"/${PN}-3.10.0-kill-gsd-automagic.patch
- epatch "${FILESDIR}"/${PN}-3.10.0-raise-gsd-dependency.patch
-
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- $(use_enable gnome gsd-plugin) \
- $(use_enable systemd libsystemd-login)
-}
diff --git a/sys-apps/gnome-disk-utility/gnome-disk-utility-3.18.2.ebuild b/sys-apps/gnome-disk-utility/gnome-disk-utility-3.18.2.ebuild
deleted file mode 100644
index 606a2f1f4211..000000000000
--- a/sys-apps/gnome-disk-utility/gnome-disk-utility-3.18.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-
-DESCRIPTION="Disk Utility for GNOME using udisks"
-HOMEPAGE="https://git.gnome.org/browse/gnome-disk-utility"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="fat gnome systemd"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.31:2[dbus]
- >=sys-fs/udisks-2.1.1:2
- >=x11-libs/gtk+-3.16.0:3
- >=app-arch/xz-utils-5.0.5
- >=app-crypt/libsecret-0.7
- dev-libs/libpwquality
- systemd? ( >=sys-apps/systemd-209:0= )
-"
-RDEPEND="${COMMON_DEPEND}
- >=media-libs/libdvdread-4.2.0
- >=media-libs/libcanberra-0.1[gtk3]
- >=x11-libs/libnotify-0.7:=
- >=x11-themes/gnome-icon-theme-symbolic-2.91
- fat? ( sys-fs/dosfstools )
- gnome? ( >=gnome-base/gnome-settings-daemon-3.8 )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.50.2
- dev-libs/appstream-glib
- dev-libs/libxslt
- virtual/pkgconfig
-"
-
-src_configure() {
- gnome2_src_configure \
- $(use_enable gnome gsd-plugin) \
- $(use_enable systemd libsystemd)
-}