summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-15 12:01:50 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-15 12:29:15 +0100
commit031759cc08e31936f9f5b9d03d2a6372c21236e5 (patch)
treedf9faff6a6e9820672815d89509842b230387c8e /sys-apps/guix
parentnet-im/slack-bin: add support for xdg (bug #624612), fix absdosym (diff)
downloadgentoo-031759cc08e31936f9f5b9d03d2a6372c21236e5.tar.gz
gentoo-031759cc08e31936f9f5b9d03d2a6372c21236e5.tar.bz2
gentoo-031759cc08e31936f9f5b9d03d2a6372c21236e5.zip
sys-apps/guix: run automake from src_prepare, bug #625166
guix build system is very eager to run automake on minor changes in .in files and breaks. Run 'automake' unconditionally in src_prepare() to workaround the failure. Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/625166 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-apps/guix')
-rw-r--r--sys-apps/guix/guix-0.13.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-apps/guix/guix-0.13.0.ebuild b/sys-apps/guix/guix-0.13.0.ebuild
index cedb13c2759a..54b553a520cc 100644
--- a/sys-apps/guix/guix-0.13.0.ebuild
+++ b/sys-apps/guix/guix-0.13.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit readme.gentoo-r1 user
+inherit autotools readme.gentoo-r1 user
DESCRIPTION="GNU package manager (nix sibling)"
HOMEPAGE="https://www.gnu.org/software/guix/"
@@ -96,16 +96,18 @@ pkg_setup() {
done
}
-src_configure() {
- # to be compatible with guix from /gnu/store
- econf \
- --localstatedir="${EPREFIX}"/var
-}
-
src_prepare() {
copy_boot_guile_binaries
default
+ # build system is very eager to run automake itself: bug #625166
+ eautomake
+}
+
+src_configure() {
+ # to be compatible with guix from /gnu/store
+ econf \
+ --localstatedir="${EPREFIX}"/var
}
src_compile() {