summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/hwdata-gentoo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/hwdata-gentoo')
-rw-r--r--sys-apps/hwdata-gentoo/Manifest1
-rw-r--r--sys-apps/hwdata-gentoo/files/0.4-openchrome.patch22
-rw-r--r--sys-apps/hwdata-gentoo/hwdata-gentoo-0.4.ebuild41
-rw-r--r--sys-apps/hwdata-gentoo/metadata.xml9
4 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/hwdata-gentoo/Manifest b/sys-apps/hwdata-gentoo/Manifest
new file mode 100644
index 000000000000..2688a68b424f
--- /dev/null
+++ b/sys-apps/hwdata-gentoo/Manifest
@@ -0,0 +1 @@
+DIST hwdata-gentoo-0.4.tar.bz2 149060 SHA256 f3bf3853f33cc20be56770f742428fb29ca97769c5984ad80093d2020136918e SHA512 dd62c51986c83ff5a9338fa20d98827cd44d86e808c9a2a52ff327dcdd941d0faed0ea4f85058485e8fc2f78e0c2fa18d3030e27fded8ed1777832ee789c189a WHIRLPOOL a7b35bf6a5b354f2483d6494a5c3f7a19fa9d61cbb6ad91528a12c947ae5562267c3552632bdb86204f494b8ab56ed583fd532bc928300262ef82d523f0b05d9
diff --git a/sys-apps/hwdata-gentoo/files/0.4-openchrome.patch b/sys-apps/hwdata-gentoo/files/0.4-openchrome.patch
new file mode 100644
index 000000000000..7b0c6e87c9d5
--- /dev/null
+++ b/sys-apps/hwdata-gentoo/files/0.4-openchrome.patch
@@ -0,0 +1,22 @@
+--- a/pcitable
++++ b/pcitable
+@@ -3688,7 +3688,7 @@
+ 0x1106 0x3336 "unknown" "VIA Technologies, Inc.|K8M890CE Host Bridge"
+ 0x1106 0x3337 "unknown" "VIA Technologies Inc.|VT8237A PCI to ISA Bridge"
+ 0x1106 0x3340 "unknown" "VIA Technologies, Inc.|PT900 Host Bridge"
+-0x1106 0x3344 "unknown" "VIA Technologies, Inc.|UniChrome Pro IGP"
++0x1106 0x3344 "Card:S3 UniChrome" "VIA Technologies, Inc.|UniChrome Pro IGP"
+ 0x1106 0x3349 "ahci" "VIA Technologies Inc.|VT8251 AHCI/SATA 4-Port Controller"
+ 0x1106 0x3351 "unknown" "VIA Technologies, Inc.|VT3351 Host Bridge"
+ 0x1106 0x3364 "unknown" "VIA Technologies, Inc.|P4M900 Host Bridge"
+--- a/Cards
++++ b/Cards
+@@ -429,7 +429,7 @@
+ DRIVER s3
+
+ NAME S3 UniChrome
+-DRIVER via
++DRIVER openchrome
+
+ NAME S3 ViRGE (generic)
+ DRIVER s3virge
diff --git a/sys-apps/hwdata-gentoo/hwdata-gentoo-0.4.ebuild b/sys-apps/hwdata-gentoo/hwdata-gentoo-0.4.ebuild
new file mode 100644
index 000000000000..cc99cc4d09ed
--- /dev/null
+++ b/sys-apps/hwdata-gentoo/hwdata-gentoo-0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Data for the hwsetup program"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wolf31o2.org/sources/hwdata/${P}.tar.bz2"
+HOMEPAGE="http://wolf31o2.org"
+
+IUSE="opengl binary-drivers"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="!sys-apps/hwdata-redhat"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-openchrome.patch
+
+ if use x86 || use amd64
+ then
+ if use opengl && use binary-drivers
+ then
+ continue
+ else
+ sed -e 's/DRIVER fglrx/DRIVER radeon/' \
+ -e 's/DRIVER nvidia/DRIVER nv/' \
+ -i "${S}"/Cards || die
+ fi
+ fi
+}
+
+src_install() {
+ dodoc ChangeLog check-cards
+ insinto /usr/share/hwdata
+ doins Cards MonitorsDB pcitable blacklist
+}
diff --git a/sys-apps/hwdata-gentoo/metadata.xml b/sys-apps/hwdata-gentoo/metadata.xml
new file mode 100644
index 000000000000..013854059a6a
--- /dev/null
+++ b/sys-apps/hwdata-gentoo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>livecd</herd>
+<use>
+ <flag name='binary-drivers'>Adds support for ATI/NVIDIA binary
+ drivers</flag>
+</use>
+</pkgmetadata>