summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2019-04-15 16:00:48 -0400
committerJustin Bronder <jsbronder@gentoo.org>2019-04-15 16:00:56 -0400
commit9377a0a43cb2a4bc366efe449419659200dc3d08 (patch)
tree18a758ba8d99caf57d3c740a4aa8b80a00ee8855 /sys-apps/hwloc
parentdev-lang/rust: avoid rust-gdbgui slot collision (diff)
downloadgentoo-9377a0a43cb2a4bc366efe449419659200dc3d08.tar.gz
gentoo-9377a0a43cb2a4bc366efe449419659200dc3d08.tar.bz2
gentoo-9377a0a43cb2a4bc366efe449419659200dc3d08.zip
sys-apps/hwloc: explicitly disable opencl
Per #683216, OpenCL will get picked up automatically. Signed-off-by: Justin Bronder <jsbronder@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/hwloc-2.0.2-r1.ebuild (renamed from sys-apps/hwloc/hwloc-2.0.2.ebuild)9
1 files changed, 3 insertions, 6 deletions
diff --git a/sys-apps/hwloc/hwloc-2.0.2.ebuild b/sys-apps/hwloc/hwloc-2.0.2-r1.ebuild
index 971dfae0ef6d..57d0a74d2dde 100644
--- a/sys-apps/hwloc/hwloc-2.0.2.ebuild
+++ b/sys-apps/hwloc/hwloc-2.0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,13 +14,11 @@ SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0/5"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="cairo cuda debug gl +numa +pci plugins svg static-libs xml X"
+IUSE="cairo cuda debug gl +pci plugins svg static-libs xml X"
# opencl support dropped with x11-drivers/ati-drivers being removed (#582406).
# Anyone with hardware is welcome to step up and help test to get it re-added.
-# dev-util/nvidia-cuda-toolkit is always multilib
-
RDEPEND=">=sys-libs/ncurses-5.9-r3:0[${MULTILIB_USEDEP}]
cairo? ( >=x11-libs/cairo-1.12.14-r4[X?,svg?,${MULTILIB_USEDEP}] )
cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1:= )
@@ -30,7 +28,6 @@ RDEPEND=">=sys-libs/ncurses-5.9-r3:0[${MULTILIB_USEDEP}]
>=x11-libs/libpciaccess-0.13.1-r1[${MULTILIB_USEDEP}]
)
plugins? ( dev-libs/libltdl:0[${MULTILIB_USEDEP}] )
- numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )
xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
@@ -57,6 +54,7 @@ multilib_src_configure() {
fi
ECONF_SOURCE=${S} econf \
+ --disable-opencl \
$(use_enable static-libs static) \
$(use_enable cairo) \
$(multilib_native_use_enable cuda) \
@@ -64,7 +62,6 @@ multilib_src_configure() {
$(multilib_native_use_enable gl) \
$(use_enable pci) \
$(use_enable plugins) \
- $(use_enable numa libnuma) \
$(use_enable xml libxml2) \
$(use_with X x)
}