summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-14 00:42:27 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-14 00:46:25 +0100
commitc1e1dccdc5ac220f0eb36ac96387df7eb81fc148 (patch)
tree71f44c65c85650ca260c604a74611909cf053af6 /sys-apps/kmod
parentnet-libs/gsoap: Removed old. (diff)
downloadgentoo-c1e1dccdc5ac220f0eb36ac96387df7eb81fc148.tar.gz
gentoo-c1e1dccdc5ac220f0eb36ac96387df7eb81fc148.tar.bz2
gentoo-c1e1dccdc5ac220f0eb36ac96387df7eb81fc148.zip
sys-apps/kmod: Update live ebuild.
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/kmod')
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index 29f71548f2a9..7738137ba641 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
-inherit bash-completion-r1 ltprune multilib python-r1
+inherit bash-completion-r1 multilib python-r1
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
@@ -21,7 +21,7 @@ HOMEPAGE="https://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug doc lzma python static-libs +tools zlib"
+IUSE="debug doc lzma python ssl static-libs +tools zlib"
# Upstream does not support running the test suite with custom configure flags.
# I was also told that the test suite is intended for kmod developers.
@@ -36,6 +36,7 @@ RDEPEND="!sys-apps/module-init-tools
!<sys-apps/systemd-216-r3
lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
python? ( ${PYTHON_DEPS} )
+ ssl? ( >=dev-libs/openssl-1.1.0:0= )
zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )
@@ -57,7 +58,7 @@ DOCS="NEWS README TODO"
src_prepare() {
default
- if [ ! -e configure ]; then
+ if [[ ! -e configure ]] ; then
if use doc; then
gtkdocize --copy --docdir libkmod/docs || die
else
@@ -85,6 +86,7 @@ src_configure() {
$(use_enable static-libs static)
$(use_enable tools)
$(use_with lzma xz)
+ $(use_with ssl openssl)
$(use_with zlib)
)
@@ -138,7 +140,7 @@ src_install() {
python_foreach_impl python_install
fi
- prune_libtool_files --modules
+ find "${ED}" -name "*.la" -delete || die
if use tools; then
local bincmd sbincmd