summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-21 10:51:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-21 10:51:33 +0100
commit1bec950fed100d95d1c2b8e9787c89ff667af598 (patch)
treefed6add632b91e33cbed478dd4e6709513a45605 /sys-apps/netplug
parentgnome-base/gdm: install pam_gdm.so in correct location, bug #599714 (diff)
downloadgentoo-1bec950fed100d95d1c2b8e9787c89ff667af598.tar.gz
gentoo-1bec950fed100d95d1c2b8e9787c89ff667af598.tar.bz2
gentoo-1bec950fed100d95d1c2b8e9787c89ff667af598.zip
sys-apps/netplug: Fixed DOWNANDOUT crash (bug #599400).
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-apps/netplug')
-rw-r--r--sys-apps/netplug/files/netplug-1.2.9.2-downandout.patch13
-rw-r--r--sys-apps/netplug/netplug-1.2.9.2-r2.ebuild71
2 files changed, 84 insertions, 0 deletions
diff --git a/sys-apps/netplug/files/netplug-1.2.9.2-downandout.patch b/sys-apps/netplug/files/netplug-1.2.9.2-downandout.patch
new file mode 100644
index 000000000000..be164e58a440
--- /dev/null
+++ b/sys-apps/netplug/files/netplug-1.2.9.2-downandout.patch
@@ -0,0 +1,13 @@
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=652418
+https://bugs.gentoo.org/599400
+
+--- a/if_info.c
++++ b/if_info.c
+@@ -186,6 +186,7 @@
+ if (newflags & IFF_UP) {
+ switch(info->state) {
+ case ST_DOWN:
++ case ST_DOWNANDOUT:
+ info->state = ST_INACTIVE;
+ break;
+
diff --git a/sys-apps/netplug/netplug-1.2.9.2-r2.ebuild b/sys-apps/netplug/netplug-1.2.9.2-r2.ebuild
new file mode 100644
index 000000000000..a147481b051c
--- /dev/null
+++ b/sys-apps/netplug/netplug-1.2.9.2-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
+HOMEPAGE="http://www.red-bean.com/~bos/"
+SRC_URI="http://www.red-bean.com/~bos/netplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND="doc? ( app-text/ghostscript-gpl
+ media-gfx/graphviz )"
+RDEPEND=""
+
+PATCHES=(
+ # Remove nested functions, #116140
+ "${FILESDIR}/${PN}-1.2.9-remove-nest.patch"
+
+ # Ignore wireless events
+ "${FILESDIR}/${PN}-1.2.9-ignore-wireless.patch"
+
+ # Fix DOWNANDOUT problem #599400
+ "${FILESDIR}/${P}-downandout.patch"
+)
+
+src_prepare() {
+ # Remove debug flags from CFLAGS
+ if ! use debug; then
+ sed -i -e "s/ -ggdb3//" Makefile || die
+ fi
+
+ # Remove -O3 and -Werror from CFLAGS
+ sed -i -e "s/ -O3//" -e "s/ -Werror//" Makefile || die
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+ emake CC="${CC}"
+
+ if use doc; then
+ emake -C docs/
+ fi
+}
+
+src_install() {
+ into /
+ dosbin netplugd
+ doman man/man8/netplugd.8
+
+ dodir /etc/netplug.d
+ exeinto /etc/netplug.d
+ newexe "${FILESDIR}/netplug-2" netplug
+
+ dodir /etc/netplug
+ echo "eth*" > "${D}"/etc/netplug/netplugd.conf || die
+
+ dodoc ChangeLog NEWS README TODO
+
+ if use doc; then
+ dodoc docs/state-machine.ps
+ fi
+}