summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGwendal Grignou <gwendal@chromium.org>2016-05-23 16:08:54 -0700
committerZac Medico <zmedico@gentoo.org>2016-05-23 16:18:58 -0700
commit377a0f042d89b7280bb4fb2f757e828b6f6736c3 (patch)
tree9b25fe943561105d1f1daef881e060ecdd6b1929 /sys-apps/nvme-cli
parentapp-antivirus/clamav: added note about hardblock and pcre dep (diff)
downloadgentoo-377a0f042d89b7280bb4fb2f757e828b6f6736c3.tar.gz
gentoo-377a0f042d89b7280bb4fb2f757e828b6f6736c3.tar.bz2
gentoo-377a0f042d89b7280bb4fb2f757e828b6f6736c3.zip
sys-apps/nvme-cli: Fix cross compilation issue.
When not setting CC, the compilation fails on option: -clang-syntax "gcc.real: error: unrecognized command line option '-clang-syntax'" Addressed the issue by properly setting the CC variable. Signed-off-by: Gwendal Grignou <gwendal@chromium.org> Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-apps/nvme-cli')
-rw-r--r--sys-apps/nvme-cli/nvme-cli-0.6.ebuild6
-rw-r--r--sys-apps/nvme-cli/nvme-cli-0_pre20150821.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/sys-apps/nvme-cli/nvme-cli-0.6.ebuild b/sys-apps/nvme-cli/nvme-cli-0.6.ebuild
index ea0ac8934b50..63984459755b 100644
--- a/sys-apps/nvme-cli/nvme-cli-0.6.ebuild
+++ b/sys-apps/nvme-cli/nvme-cli-0.6.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="NVM-Express user space tooling for Linux"
HOMEPAGE="https://github.com/linux-nvme/nvme-cli"
SRC_URI="https://github.com/linux-nvme/nvme-cli/archive/v${PV}.tar.gz"
@@ -24,6 +26,10 @@ src_prepare() {
default
}
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX=/usr install
}
diff --git a/sys-apps/nvme-cli/nvme-cli-0_pre20150821.ebuild b/sys-apps/nvme-cli/nvme-cli-0_pre20150821.ebuild
index 56a32344df46..997f71995782 100644
--- a/sys-apps/nvme-cli/nvme-cli-0_pre20150821.ebuild
+++ b/sys-apps/nvme-cli/nvme-cli-0_pre20150821.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit toolchain-funcs
+
DESCRIPTION="NVM-Express user space tooling for Linux"
HOMEPAGE="https://github.com/linux-nvme/nvme-cli"
EGIT_COMMIT="709571d77bf618921fd719253da677742c673d06"
@@ -24,6 +26,10 @@ src_prepare() {
-i Documentation/Makefile || die
}
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX=/usr install
}