summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-01-08 03:12:57 -0600
committerTim Harder <radhermit@gentoo.org>2019-01-08 03:38:19 -0600
commit4ce423007b2ff323a55da040c7cb95ff9e0134d2 (patch)
tree22a828b8269fcf10029d5fc1ee7ad5993f9c7d58 /sys-apps/pkgcore/pkgcore-9999.ebuild
parentsys-fs/fuse: remove old (diff)
downloadgentoo-4ce423007b2ff323a55da040c7cb95ff9e0134d2.tar.gz
gentoo-4ce423007b2ff323a55da040c7cb95ff9e0134d2.tar.bz2
gentoo-4ce423007b2ff323a55da040c7cb95ff9e0134d2.zip
sys-apps/pkgcore: update live ebuild deps
And only build man pages for the live ebuild if the doc USE flags is enabled. Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore/pkgcore-9999.ebuild')
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index ae58325b3b80..34a210caba47 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -21,25 +21,24 @@ LICENSE="|| ( BSD GPL-2 )"
SLOT="0"
IUSE="doc test"
-if [[ ${PV} == *9999 ]] ; then
- SPHINX="dev-python/sphinx[${PYTHON_USEDEP}]"
-else
- SPHINX="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-fi
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
if [[ ${PV} == *9999 ]]; then
RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
RDEPEND+=" >=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}
- ${SPHINX}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
python_compile_all() {
- esetup.py build_man $(usex doc "build_docs" "")
+ local esetup_args=( $(usex doc "--enable-html-docs" "") )
+ # only build man pages for live ebuilds if doc USE flag is enabled
+ [[ ${PV} == *9999 ]] && esetup_args+=( $(usex doc "--enable-man-pages" "") )
+ esetup.py build "${esetup_args[@]}"
}
python_test() {
@@ -47,8 +46,9 @@ python_test() {
}
python_install_all() {
- distutils-r1_python_install install_man \
- $(usex doc "install_docs --path="${ED%/}"/usr/share/doc/${PF}/html" "")
+ esetup.py install_docs \
+ --docdir="${ED%/}/usr/share/doc/${PF}" \
+ --mandir="${ED%/}/usr/share/man"
distutils-r1_python_install_all
}