summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-11 10:31:29 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 12:22:44 +0100
commit9a8ea1b82d5ca973287efd3b32603a36e190629f (patch)
treee85b80d2ca2686cb100a4981216c1a561a419ed4 /sys-apps/smc-sum-driver
parentgames-server/minecraft-server: New package (diff)
downloadgentoo-9a8ea1b82d5ca973287efd3b32603a36e190629f.tar.gz
gentoo-9a8ea1b82d5ca973287efd3b32603a36e190629f.tar.bz2
gentoo-9a8ea1b82d5ca973287efd3b32603a36e190629f.zip
sys-apps/smc-sum-driver: New package
Bug: https://bugs.gentoo.org/651558 Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9106 Closes: https://bugs.gentoo.org/651558
Diffstat (limited to 'sys-apps/smc-sum-driver')
-rw-r--r--sys-apps/smc-sum-driver/Manifest1
-rw-r--r--sys-apps/smc-sum-driver/files/makefile15
-rw-r--r--sys-apps/smc-sum-driver/metadata.xml17
-rw-r--r--sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild41
4 files changed, 74 insertions, 0 deletions
diff --git a/sys-apps/smc-sum-driver/Manifest b/sys-apps/smc-sum-driver/Manifest
new file mode 100644
index 000000000000..75709223439a
--- /dev/null
+++ b/sys-apps/smc-sum-driver/Manifest
@@ -0,0 +1 @@
+DIST sum_driver_V1.6.0_20151201.tar.gz 1423921 BLAKE2B 76e2439148749b708a51e0d9c95545b53762f03793e6b2ea6e63e9f79aaad77432f728e94713e0cfd4085e8b090b6e0ff8e779e2627764e71794453cb7e02b49 SHA512 809fdf164e29aabde74306d966de7e07488d8dacc01963b56486477f23bdf3a469d059bc5d302aedbfd4b8dc854a82357747add2626cc22d0ab3898c7bc0a625
diff --git a/sys-apps/smc-sum-driver/files/makefile b/sys-apps/smc-sum-driver/files/makefile
new file mode 100644
index 000000000000..35564dcc8fec
--- /dev/null
+++ b/sys-apps/smc-sum-driver/files/makefile
@@ -0,0 +1,15 @@
+obj-m := sum_bios.o
+
+KVERSION := $(shell uname -r)
+KDIR := /lib/modules/$(KVERSION)/build
+PWD := $(shell pwd)
+
+EXTRA_CFLAGS = $(CFLAGS) -Wno-incompatible-pointer-types
+EXTRA_LDFLAGS = $(LDFLAGS)
+
+default:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules
+
+install:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules_install
+
diff --git a/sys-apps/smc-sum-driver/metadata.xml b/sys-apps/smc-sum-driver/metadata.xml
new file mode 100644
index 000000000000..3720c27565ed
--- /dev/null
+++ b/sys-apps/smc-sum-driver/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This is the kernel module for the Supermicro Update Manager (SUM).
+ It's needed to access specific low level elements, like BIOS.
+ Supermicro SuperDoctor5 will also need this kernel module.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild
new file mode 100644
index 000000000000..f37dc6d72d09
--- /dev/null
+++ b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver linux-mod
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN//-/_}"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN/smc_/}_V${MY_PV}"
+
+DESCRIPTION="Supermicro Update Manager (SUM) kernel module"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_P}_${MY_DATE}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"/${MY_P}/Linux
+
+BUILD_TARGETS="default"
+MODULE_NAMES="sum_bios(misc:${S})"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "sftp://dataharbor.supermicro.com"
+ elog "Username: dpguest\$ts"
+ elog "Password: supermicro!@#"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_prepare() {
+ # Install new Makefile to respect users CFLAGS and LDFLAGS
+ cp "${FILESDIR}"/makefile Makefile
+
+ default
+}