summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-01 00:13:07 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-01 09:36:59 +0200
commitd723cdec15635a4dc4522028cb2e05b6380e4670 (patch)
tree6f47a63b6f620ac9fd9cc2e51e2a2d87a62dc418 /sys-apps/superdiag
parentdev-lua/luaossl: takeover maintainership (diff)
downloadgentoo-d723cdec15635a4dc4522028cb2e05b6380e4670.tar.gz
gentoo-d723cdec15635a4dc4522028cb2e05b6380e4670.tar.bz2
gentoo-d723cdec15635a4dc4522028cb2e05b6380e4670.zip
sys-apps/superdiag: New package
Closes: https://bugs.gentoo.org/665242 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9780
Diffstat (limited to 'sys-apps/superdiag')
-rw-r--r--sys-apps/superdiag/Manifest1
-rw-r--r--sys-apps/superdiag/metadata.xml24
-rw-r--r--sys-apps/superdiag/superdiag-1.1.0.20180731.ebuild82
3 files changed, 107 insertions, 0 deletions
diff --git a/sys-apps/superdiag/Manifest b/sys-apps/superdiag/Manifest
new file mode 100644
index 000000000000..93dc6ed99a01
--- /dev/null
+++ b/sys-apps/superdiag/Manifest
@@ -0,0 +1 @@
+DIST SuperDiag_1.1.0_20180731_package.zip 2564515 BLAKE2B 9ae34682daf5aa8996989c434906dd59f64e569a1cd1ae107d1e7861430ae028829efd1a1aa1ba2b5269d13e0ac2bef33b106a945fbd800fba6766b10f7486a5 SHA512 b79eae3063fc1425ee2a7a71304ae8993da52e9a2a8b2565e5f4fe0f3f3cdf8a7016cf765dab9e440c71cb8ff6b311fa2e4067459d76268bcf2697e8344c4e9a
diff --git a/sys-apps/superdiag/metadata.xml b/sys-apps/superdiag/metadata.xml
new file mode 100644
index 000000000000..c8ab6cc03ab4
--- /dev/null
+++ b/sys-apps/superdiag/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Super Diagnostics provides offline the capability to determine
+ the health of Supermicro server's components, including CPU, memory and I/O.
+ Features: Designed for Supermicro Sytems, offline diagnostics,
+ command line interface (CLI), local and remote diagnostics,
+ automatically collects information on detected devices,
+ test results reported in output files and flexible test coverage.
+ </longdescription>
+ <use>
+ <flag name="iso">Install an iso image, which can be used with <pkg>sys-apps/smc-sum</pkg>.</flag>
+ <flag name="usb">Install all files, which are needed for an installation on an usb thumb drive.</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-apps/superdiag/superdiag-1.1.0.20180731.ebuild b/sys-apps/superdiag/superdiag-1.1.0.20180731.ebuild
new file mode 100644
index 000000000000..99c892c14414
--- /dev/null
+++ b/sys-apps/superdiag/superdiag-1.1.0.20180731.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_BUILD="0724"
+MY_DATE="$(ver_cut 4)"
+MY_DATE_ISO="20180724"
+MY_PN="SuperDiag"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN}_${MY_PV}_${MY_DATE}"
+
+DESCRIPTION="Provides the capability to determine the health of Supermicro servers components"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_${MY_DATE}_package.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+IUSE="iso usb"
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ unpack "${S}"/${MY_P}.zip
+
+ if use iso; then
+ unzip ${MY_P}/Diagnose_Remotely/ISOFor${MY_PN}_v${MY_PV}_${MY_BUILD}.zip -d iso || die
+ fi
+
+ if use usb; then
+ unzip ${MY_P}/Diagnose_Remotely/USBFor${MY_PN}_v${MY_PV}_${MY_BUILD}.zip -d usb || die
+ fi
+}
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SDO"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ insinto /usr/share/superdiag
+ doins ${MY_P}/startup.nsh ${MY_P}/${MY_PN}_v${MY_PV}.efi ${MY_P}/EFI/Boot/BootX64.efi
+
+ insinto /usr/share/superdiag/Picture
+ doins ${MY_P}/Picture/*.bmp
+
+ insinto /usr/share/superdiag/SelData
+ doins ${MY_P}/SelData/*.dat
+
+ local DOCS=(
+ "Superdiag_${MY_PV}_addendum_release_notes.docx"
+ "${MY_P}/Supermicro Super Diagnostics Offline readme.txt"
+ "${MY_P}/Supermicro Super Diagnostics Offline User Guide V${MY_PV}.pdf"
+ )
+ dodoc "${DOCS[@]}"
+
+ if use iso; then
+ insinto /usr/share/superdiag/ISO
+ doins iso/${MY_PN}_v${MY_PV}_${MY_DATE_ISO}.iso
+
+ newdoc iso/Readme.txt Readme.ISO.txt
+ fi
+
+ if use usb; then
+ insinto /usr/share/superdiag/USB
+ doins usb/STARTUP.nsh
+
+ dosym ../BootX64.efi /usr/share/superdiag/USB/BootX64.efi
+ dosym ../${MY_PN}_v${MY_PV}.efi /usr/share/superdiag/USB/${MY_PN}_v${MY_PV}.efi
+ dosym ../Picture /usr/share/superdiag/USB/Picture
+ dosym ../SelData /usr/share/superdiag/USB/SelData
+
+ newdoc usb/Readme.txt Readme.USB.txt
+ fi
+}