summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-02 16:11:14 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-02 17:14:44 +0100
commit87d2eb716c31062361cf158a49a6be5c37d0f292 (patch)
tree027fe7aae7632bef5c0e87dc9700d9c9725810b9 /sys-apps/superiotool
parentsys-apps/syscriptor: Port to EAPI 6 (diff)
downloadgentoo-87d2eb716c31062361cf158a49a6be5c37d0f292.tar.gz
gentoo-87d2eb716c31062361cf158a49a6be5c37d0f292.tar.bz2
gentoo-87d2eb716c31062361cf158a49a6be5c37d0f292.zip
sys-apps/superiotool: Port to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-apps/superiotool')
-rw-r--r--sys-apps/superiotool/Manifest2
-rw-r--r--sys-apps/superiotool/superiotool-6637.ebuild16
-rw-r--r--sys-apps/superiotool/superiotool-99999999.ebuild16
3 files changed, 13 insertions, 21 deletions
diff --git a/sys-apps/superiotool/Manifest b/sys-apps/superiotool/Manifest
index f29ac5386668..81eb3d416236 100644
--- a/sys-apps/superiotool/Manifest
+++ b/sys-apps/superiotool/Manifest
@@ -1 +1 @@
-DIST superiotool-6637.tar.xz 27364 SHA256 e21e091c7679c2eeac66aa49499c02587d64a41b3b36449f4ec06dafc8f0ba21 SHA512 dafb732b33205d1bdd368c1f752c7ba78cfb9f6174fc72075b9e8dcae962ab9ef10eb0860052a5925167b91e5b056f6b8a4a316799661d3950a630020f4330fd WHIRLPOOL 70ee5da7946cd93d978db2094dee1466a91239db96f640e5e2b7aa6d9487ccc43229e570bd084dcd6ef27353752059dfaa6fdf5b414d4eadf657549d0998bf39
+DIST superiotool-6637.tar.xz 27364 BLAKE2B be0fd054f1385c20ca1d3da04052f7155da77211c1a4253c58c0ee272944e4134b1df6213934ea0ab6c297da9ab09ceab1cc00dcd775633d7ba50f46cba8ffb8 SHA512 dafb732b33205d1bdd368c1f752c7ba78cfb9f6174fc72075b9e8dcae962ab9ef10eb0860052a5925167b91e5b056f6b8a4a316799661d3950a630020f4330fd
diff --git a/sys-apps/superiotool/superiotool-6637.ebuild b/sys-apps/superiotool/superiotool-6637.ebuild
index 9cd57fadcfca..83db272b25ab 100644
--- a/sys-apps/superiotool/superiotool-6637.ebuild
+++ b/sys-apps/superiotool/superiotool-6637.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
-if [[ ${PV} == "99999999" ]] ; then
+if [[ ${PV} == *99999999 ]] ; then
ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
inherit subversion
- SRC_URI=""
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -26,6 +25,8 @@ DEPEND="${RDEPEND}
app-arch/xz-utils"
src_prepare() {
+ default
+
sed -i \
-e 's:-Werror ::' \
-e 's:-O2 ::' \
@@ -40,8 +41,3 @@ src_compile() {
CC="$(tc-getCC)" \
SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc README
-}
diff --git a/sys-apps/superiotool/superiotool-99999999.ebuild b/sys-apps/superiotool/superiotool-99999999.ebuild
index 9cd57fadcfca..83db272b25ab 100644
--- a/sys-apps/superiotool/superiotool-99999999.ebuild
+++ b/sys-apps/superiotool/superiotool-99999999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
-if [[ ${PV} == "99999999" ]] ; then
+if [[ ${PV} == *99999999 ]] ; then
ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
inherit subversion
- SRC_URI=""
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -26,6 +25,8 @@ DEPEND="${RDEPEND}
app-arch/xz-utils"
src_prepare() {
+ default
+
sed -i \
-e 's:-Werror ::' \
-e 's:-O2 ::' \
@@ -40,8 +41,3 @@ src_compile() {
CC="$(tc-getCC)" \
SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc README
-}