summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2018-02-20 18:29:41 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-02-20 22:38:49 +0100
commit68d4b4f7e4b523d3a27474f594edac1498f2bf5e (patch)
tree715d25412110c99e194cf11dd26b22cc8f1662b3 /sys-apps/thunderbolt-software-user-space
parentnet-libs/zmqpp: version bump to 4.2.0. (diff)
downloadgentoo-68d4b4f7e4b523d3a27474f594edac1498f2bf5e.tar.gz
gentoo-68d4b4f7e4b523d3a27474f594edac1498f2bf5e.tar.bz2
gentoo-68d4b4f7e4b523d3a27474f594edac1498f2bf5e.zip
sys-apps/thunderbolt-software-user-space: new package.
thunderbolt-software-user-space is a tool to talk to the tunderbolt kernel driver and approve thunderbolt devices. Closes: https://bugs.gentoo.org/648312 Closes: https://github.com/gentoo/gentoo/pull/7239 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/thunderbolt-software-user-space')
-rw-r--r--sys-apps/thunderbolt-software-user-space/Manifest2
-rw-r--r--sys-apps/thunderbolt-software-user-space/metadata.xml16
-rw-r--r--sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild27
-rw-r--r--sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3.ebuild27
4 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/thunderbolt-software-user-space/Manifest b/sys-apps/thunderbolt-software-user-space/Manifest
new file mode 100644
index 000000000000..c38310964b8f
--- /dev/null
+++ b/sys-apps/thunderbolt-software-user-space/Manifest
@@ -0,0 +1,2 @@
+DIST thunderbolt-software-user-space-0.9.2.tar.gz 14485 BLAKE2B 8a471888fefbbd7949454b176845b4162b08736d60a86b53f2330e115b776d1ef25b1a706e6fc76661551339525876ddfb621c52301d9327b0c7be0b1abd1f9c SHA512 fbd5902f3f06d3cfec309a972fe5dc32e87eab39668b2c07401bd79ad9af2210f8db41ecdd30cfae34ba24b03dc47df439c2fcd2e74da55d1101237f723b4540
+DIST thunderbolt-software-user-space-0.9.3.tar.gz 22186 BLAKE2B afc614d0d2f7de3c23988e08c0053d24a04be51d22986497e3863b76ad59f1a8a9e2ab323210df27a3fa2f07ab05122666a3c6bfde146250f0854b2dfb6748f8 SHA512 b8bcb31d864376c644f9813abf2d090cc3239271df8a8e71ff7d5e398e993d4d01e94ba5fc1bc13d7dd0fa861b4b918a6df0724ca43f54a5e706ec67f3c7846b
diff --git a/sys-apps/thunderbolt-software-user-space/metadata.xml b/sys-apps/thunderbolt-software-user-space/metadata.xml
new file mode 100644
index 000000000000..8fb8d2b55b7d
--- /dev/null
+++ b/sys-apps/thunderbolt-software-user-space/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Jonas Licht</name>
+ <email>jonas.licht@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Installs the tools tbtacl and tbtadm for Thunderbolt device approval, handling the ACL and more.
+ Also install udev rules to mange acls.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild
new file mode 100644
index 000000000000..98f4f364ebe1
--- /dev/null
+++ b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils linux-info
+DESCRIPTION="Thunderbolt(TM) user-space components"
+HOMEPAGE="https://github.com/intel/thunderbolt-software-user-space"
+SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+app-text/txt2tags
+dev-libs/boost
+"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ CONFIG_CHECK="THUNDERBOLT"
+ ERROR_THUNDERBOLT="This program talks to the thunderbolt kernel driver, so please enable it."
+ CONFIG_CHECK="HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderpolt needs pci hotplug support, so please enable it."
+ check_extra_config
+}
diff --git a/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3.ebuild b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3.ebuild
new file mode 100644
index 000000000000..98f4f364ebe1
--- /dev/null
+++ b/sys-apps/thunderbolt-software-user-space/thunderbolt-software-user-space-0.9.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils linux-info
+DESCRIPTION="Thunderbolt(TM) user-space components"
+HOMEPAGE="https://github.com/intel/thunderbolt-software-user-space"
+SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+app-text/txt2tags
+dev-libs/boost
+"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ CONFIG_CHECK="THUNDERBOLT"
+ ERROR_THUNDERBOLT="This program talks to the thunderbolt kernel driver, so please enable it."
+ CONFIG_CHECK="HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderpolt needs pci hotplug support, so please enable it."
+ check_extra_config
+}