summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:44:41 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:45:04 +0100
commitcdccf0cca5cfff203bc806c69b37b27b7f07b7f6 (patch)
tree86be7d93dcdc7fbdb7b6ee8b9d0582e1825953f3 /sys-apps/toybox
parentapp-text/tofrodos: bump to v1.7.13 (diff)
downloadgentoo-cdccf0cca5cfff203bc806c69b37b27b7f07b7f6.tar.gz
gentoo-cdccf0cca5cfff203bc806c69b37b27b7f07b7f6.tar.bz2
gentoo-cdccf0cca5cfff203bc806c69b37b27b7f07b7f6.zip
sys-apps/toybox: bump to v0.7.8
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/toybox')
-rw-r--r--sys-apps/toybox/Manifest1
-rw-r--r--sys-apps/toybox/toybox-0.7.8.ebuild57
-rw-r--r--sys-apps/toybox/toybox-9999.ebuild16
3 files changed, 66 insertions, 8 deletions
diff --git a/sys-apps/toybox/Manifest b/sys-apps/toybox/Manifest
index 7fc0f6a84567..02052b026aff 100644
--- a/sys-apps/toybox/Manifest
+++ b/sys-apps/toybox/Manifest
@@ -1,3 +1,4 @@
DIST toybox-0.7.5.tar.gz 818815 BLAKE2B 0d91eb07b9c2e64c611be24eb09aac7ffc26d65f3dd39ee7663419e4eff1e9d559b7b6e8df0dc8e13986124aefa706b343c4a3521466f2bdf657d4c9a82a9fc2 SHA512 f0cc54da2394ed14b41dbc80bf674f86989f0312b645b9e1e5403fb0a3282cafce9608b2d738ab2dbb6fe3779eed70d51133a867c6ea76683dd7e6de245df127
DIST toybox-0.7.6.tar.gz 834351 BLAKE2B 7c6737a8b16f77fd7a5e389be17ef8eb41d28718e46231ec1aa48af0a0ec1cbdc1c0b74670c3f79f58a5b0547f47aa6e5ccbaccc5451b12a80e1c566ee49a30d SHA512 1ed06114f5feb46e642bfeee517366a16c0a5d76562841a3cdf6b003bb330be10d4ac5009c7cf845eb5ea99bb8ae8b4291c413bbd45fd89c2ae3e4a69c1455bb
DIST toybox-0.7.7.tar.gz 843039 BLAKE2B fb4ef2ad483acd2b42905e765f7287b41fa8b1822796579c4a57a8ad3f5a3cdb8bbcd0e6790eddc8daf2ec41c50be478c7d19623d1c8db2e7b1d4db8b52fbbc6 SHA512 89369662eaf48bb52909f49932b98395eed6e672f6a37387819a02ba9c33f6b737686782ca3bf0ed0f9b60e1e2fff88ad1ebb678999582986acfec371d100827
+DIST toybox-0.7.8.tar.gz 903344 BLAKE2B e223dabd7b44a050bb884d595235ea469524ffbcf3b29ee8a106354dff3250b5e9c7922cb8b499ff343e170735e29b321b9c00c370c67a1d20c8a5e44ab2bdd2 SHA512 125e4b22deda1e707a62c49b40bf7ac8a36122af27fd70ed45c651a61b5607765cf1c9b3b1c3103c0a5b5f4e7760a50e87ac62bfc89aa870a22ae8ad0aacad65
diff --git a/sys-apps/toybox/toybox-0.7.8.ebuild b/sys-apps/toybox/toybox-0.7.8.ebuild
new file mode 100644
index 000000000000..722524f40455
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.7.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multiprocessing savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/landley/toybox.git"
+else
+ SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="https://landley.net/code/toybox/"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ default
+ restore_config .config
+}
+
+src_configure() {
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, so we will save a default one"
+ emake -j1 defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ tc-export CC STRIP
+ export HOSTCC=$(tc-getBUILD_CC)
+ unset CROSS_COMPILE
+ export CPUS=$(makeopts_jobs)
+ emake V=1
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ save_config .config
+ newbin generated/unstripped/toybox toybox
+}
diff --git a/sys-apps/toybox/toybox-9999.ebuild b/sys-apps/toybox/toybox-9999.ebuild
index 3fc7451c7023..722524f40455 100644
--- a/sys-apps/toybox/toybox-9999.ebuild
+++ b/sys-apps/toybox/toybox-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI="7"
-inherit eutils multiprocessing savedconfig toolchain-funcs
+inherit multiprocessing savedconfig toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/landley/toybox.git"
else
- SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.bz2"
+ SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -17,7 +17,7 @@ fi
RESTRICT="test"
DESCRIPTION="Common linux commands in a multicall binary"
-HOMEPAGE="http://landley.net/code/toybox/"
+HOMEPAGE="https://landley.net/code/toybox/"
# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
LICENSE="BSD-2"
@@ -25,7 +25,7 @@ SLOT="0"
IUSE=""
src_prepare() {
- epatch_user
+ default
restore_config .config
}
@@ -35,7 +35,7 @@ src_configure() {
return 0
else
einfo "Could not locate user configfile, so we will save a default one"
- emake defconfig > /dev/null
+ emake -j1 defconfig > /dev/null
fi
}
@@ -53,5 +53,5 @@ src_test() {
src_install() {
save_config .config
- newbin toybox_unstripped toybox
+ newbin generated/unstripped/toybox toybox
}