summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2017-10-03 13:37:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-10-03 13:43:54 -0500
commit2e5db452215a9e4c8c69b05451c34103fcde285c (patch)
treee543df861288f4a73dc4de9b0ff6f8da22a3fe44 /sys-apps
parentsys-apps/s6-portable-utils: 2.2.1.1 version bump (diff)
downloadgentoo-2e5db452215a9e4c8c69b05451c34103fcde285c.tar.gz
gentoo-2e5db452215a9e4c8c69b05451c34103fcde285c.tar.bz2
gentoo-2e5db452215a9e4c8c69b05451c34103fcde285c.zip
sys-apps/s6-linux-utils: 2.4.0.1 version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6-linux-utils/Manifest1
-rw-r--r--sys-apps/s6-linux-utils/s6-linux-utils-2.4.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/s6-linux-utils/Manifest b/sys-apps/s6-linux-utils/Manifest
index 2d86430b450b..e13a9e55dee8 100644
--- a/sys-apps/s6-linux-utils/Manifest
+++ b/sys-apps/s6-linux-utils/Manifest
@@ -3,3 +3,4 @@ DIST s6-linux-utils-2.1.0.0.tar.gz 40996 SHA256 3523ba84ba524198711b2de3edaaf620
DIST s6-linux-utils-2.2.0.0.tar.gz 40863 SHA256 587745abfbf2cc631bb54dd2b3fd29f39b723e3c50e28165138a85c98fda35f9 SHA512 5d0fcd29f7a03146b5296d7164326f76af95a8632df4204021d9ae30b1f03590e7f25d410f07639cf741a455f9624f9410b2e7836ae6838916da50be1527ae7f WHIRLPOOL 49f3ff3882100cc0176915bcc17f824b7b49c0e2bef8037c0643b1bf6e88df2221d5cdd8144110e03631433d80a0d35283b3fa8d338c3ecf2681c756c193280a
DIST s6-linux-utils-2.3.0.0.tar.gz 40377 SHA256 6189d77bf4111d5cb80f7fd60525b2eeca5d2b3a9b16ccadacc7333da7b40c84 SHA512 09e5744f6ac35d33c9c61ffc0ae6c8697e5d1816e5bd83e2dd4385d54a8f6da9c43fe2b1cb1cacba6f30a53cd7d9487a12b44028b20b110c74d6c3016d0511a1 WHIRLPOOL 9747bd1f3b8b95381a5ce8787efa82dd5b64375050e67dd4b05c66b8afa18fbc90960e8831441de14d0396600795dcb6ac80eb54d03e2b92f0690e82a408480f
DIST s6-linux-utils-2.4.0.0.tar.gz 44050 SHA256 3afb7b972a9d54042ac0aabde5489be90039374b6a90ef45f7f32ce2e83d1e63 SHA512 68f3dbd230d99afeeb47310ec544b7d9fa4658b580567f81100f988fd90d4db239938eae9b999d7be9ee384d9ac51ac61ff5d2d620a1b9711ff5663ff2aa6021 WHIRLPOOL 1ef2d55ef3f90c321c738a75135fe18a2e6fc1b92054db5574f0a84d2f87a60ab1dda7924c8bab7db7d16cb60971678b55290f5391532e109f5ed04e990b58cd
+DIST s6-linux-utils-2.4.0.1.tar.gz 44248 SHA256 9562ef293c916c4448d16fcbbc065eb28fd995ac34cd3538179cbc3ee056ab93 SHA512 91c1ed1ea329394158e859e8fd5741a2589ba8d0f8c2d0a0d14b989bd99dce3666d3de78f6be676b672824d21f0e40bf03ede198ec59e391791c092a65f835d5 WHIRLPOOL facb83f1749c4ee5f47c82e907c0ccc506dd69a0ce84a00568da4b39d60be66a30d6277c134fc1639b6a48c7e92b5a231364de1342eabd7c3becdfb58a49454d
diff --git a/sys-apps/s6-linux-utils/s6-linux-utils-2.4.0.1.ebuild b/sys-apps/s6-linux-utils/s6-linux-utils-2.4.0.1.ebuild
new file mode 100644
index 000000000000..148e80db555f
--- /dev/null
+++ b/sys-apps/s6-linux-utils/s6-linux-utils-2.4.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="set of tiny linux utilities"
+HOMEPAGE="https://www.skarnet.org/software/s6-linux-utils/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+DEPEND=">=sys-devel/make-3.81
+ static? (
+ >=dev-libs/skalibs-2.6.0.0[static-libs]
+ )
+ !static? (
+ >=dev-libs/skalibs-2.6.0.0
+ )
+"
+RDEPEND="
+ !static? (
+ >=dev-libs/skalibs-2.6.0.0:=
+ )
+"
+
+HTML_DOCS="doc/*"
+
+src_prepare() {
+ default
+
+ # Remove QA warning about LDFLAGS addition
+ sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
+
+ # configure overrides gentoo's -fstack-protector default
+ sed -i "/^tryflag CFLAGS_AUTO -fno-stack-protector$/d" "${S}/configure" || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --dynlibdir=/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/$(get_libdir) \
+ --with-lib=/usr/$(get_libdir)/skalibs \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs \
+ $(use_enable static allstatic) \
+ $(use_enable static static-libc)
+}