summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-07 03:00:56 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-07 03:00:56 -0500
commit4a1ef46c041d7851ff0bb27ddb3bd321afebed8f (patch)
treebf6e5f714dc93b1d321553c37da67612ea59135c /sys-apps
parentsys-libs/gpm: disable EMACS/ELISP at all build steps #586880 (diff)
downloadgentoo-4a1ef46c041d7851ff0bb27ddb3bd321afebed8f.tar.gz
gentoo-4a1ef46c041d7851ff0bb27ddb3bd321afebed8f.tar.bz2
gentoo-4a1ef46c041d7851ff0bb27ddb3bd321afebed8f.zip
sys-apps/memtest86+: fix missing ssp flags on test/random objects #590974
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch21
-rw-r--r--sys-apps/memtest86+/memtest86+-5.01-r2.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch b/sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch
new file mode 100644
index 000000000000..8a76d0464143
--- /dev/null
+++ b/sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch
@@ -0,0 +1,21 @@
+make sure we re-use the existing CFLAGS settings so that we get all the right
+flags (like -fno-stack-protector). just append the few changes we want (the
+optimization levels).
+
+https://bugs.gentoo.org/590974
+
+--- a/Makefile
++++ b/Makefile
+@@ -52,10 +52,10 @@ reloc.o: reloc.c
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++test.o: CFLAGS += -O0
+
+ random.o: random.c
+- $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
++random.o: CFLAGS += -O3
+
+ # rule for build number generation
+ build_number:
diff --git a/sys-apps/memtest86+/memtest86+-5.01-r2.ebuild b/sys-apps/memtest86+/memtest86+-5.01-r2.ebuild
index 831cf329d286..7470da9783c3 100644
--- a/sys-apps/memtest86+/memtest86+-5.01-r2.ebuild
+++ b/sys-apps/memtest86+/memtest86+-5.01-r2.ebuild
@@ -31,6 +31,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-reboot-def.patch #548312
epatch "${FILESDIR}"/${P}-no-clean.patch #557890
epatch "${FILESDIR}"/${P}-no-C-headers.patch #592638
+ epatch "${FILESDIR}"/${P}-test-random-cflags.patch #590974
if use serial ; then
sed -i \