summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-29 21:09:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-29 21:09:27 +0200
commit55dd8bb9d34c6a2a9f538e9b6fdbd4d2d4bb7c20 (patch)
treec709bf1d6a67893a290631ebe8eefb0b6d023c3a /sys-auth
parentmedia-sound/coquillo: Drop old (diff)
downloadgentoo-55dd8bb9d34c6a2a9f538e9b6fdbd4d2d4bb7c20.tar.gz
gentoo-55dd8bb9d34c6a2a9f538e9b6fdbd4d2d4bb7c20.tar.bz2
gentoo-55dd8bb9d34c6a2a9f538e9b6fdbd4d2d4bb7c20.zip
sys-auth/elogind: 236.1 version bump
Bug: https://bugs.gentoo.org/644118 Bug: https://bugs.gentoo.org/649834 Closes: https://bugs.gentoo.org/654166 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/elogind/Manifest1
-rw-r--r--sys-auth/elogind/elogind-236.1.ebuild118
-rw-r--r--sys-auth/elogind/files/elogind-236.1-docs.patch24
3 files changed, 143 insertions, 0 deletions
diff --git a/sys-auth/elogind/Manifest b/sys-auth/elogind/Manifest
index 25d08cb3a62b..fb21f216ddfd 100644
--- a/sys-auth/elogind/Manifest
+++ b/sys-auth/elogind/Manifest
@@ -1 +1,2 @@
DIST elogind-235.2.tar.gz 975652 BLAKE2B c568b5eec89da14f55211cf4405d96b4bb1ea274d1237739a92c4f3585a6181a3e17dc7ed2af5161c649cae2149b3bd25f4212cf5a304383b254e39d7aa0b378 SHA512 6fa9194e8c21fa3d3caf6f9499f772dbfe38b9d40d8a0fe43ee32ad4b2acd672a78798d00694d1e0d6107625f4f3f06b71e0a5466ed4be446d670f9bcd961313
+DIST elogind-236.1.tar.gz 1050387 BLAKE2B d0d295210eb07374cae738f55b472d9410f68c9e7f318dd736b5fcb5c0409c3da144988d8042b1e3b103d34d7a02471b4e316a924c9b1640c605fc73972de3da SHA512 ab4989f4467ef001bb8b837035bee870beaf5ec5fa2389649bdcad2fe7bbf82691bfd3176cf9a3bf3b5c232c77210f431f2d38ebdbfd09f5a7868cd50e476c59
diff --git a/sys-auth/elogind/elogind-236.1.ebuild b/sys-auth/elogind/elogind-236.1.ebuild
new file mode 100644
index 000000000000..4a29aef92814
--- /dev/null
+++ b/sys-auth/elogind/elogind-236.1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info meson pam udev xdg-utils
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+acl debug doc +pam +policykit selinux"
+
+COMMON_DEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd
+"
+PDEPEND="
+ sys-apps/dbus
+ policykit? ( sys-auth/polkit )
+"
+
+PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
+ local cgroupmode="legacy"
+
+ if [[ "xhybrid" = "x${rccgroupmode}" ]] ; then
+ cgroupmode="hybrid"
+ elif [[ "xunified" = "x${rccgroupmode}" ]] ; then
+ cgroupmode="unified"
+ fi
+
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ -Dpamlibdir=$(getpam_mod_dir)
+ -Dudevrulesdir="$(get_udevdir)"/rules.d
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ -Drootlibdir="${EPREFIX}"/$(get_libdir)
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
+ -Drootprefix="${EPREFIX}/"
+ -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions"
+ -Dman=auto
+ -Dsmack=true
+ -Dcgroup-controller=openrc
+ -Ddefault-hierarchy=${cgroupmode}
+ -Ddefault-kill-user-processes=false
+ -Dacl=$(usex acl true false)
+ -Ddebug=$(usex debug elogind false)
+ --buildtype $(usex debug debug release)
+ -Dhtml=$(usex doc auto false)
+ -Dpam=$(usex pam true false)
+ -Dselinux=$(usex selinux true false)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ DOCS+=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
+
+ meson_src_install
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
+ elog "elogind is currently started from boot runlevel."
+ elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then
+ ewarn "elogind is currently started from default runlevel."
+ ewarn "Please remove elogind from the default runlevel and"
+ ewarn "add it to the boot runlevel by:"
+ ewarn "# rc-update del elogind default"
+ ewarn "# rc-update add elogind boot"
+ else
+ ewarn "elogind is currently not started from any runlevel."
+ ewarn "You may add it to the boot runlevel by:"
+ ewarn "# rc-update add elogind boot"
+ fi
+}
diff --git a/sys-auth/elogind/files/elogind-236.1-docs.patch b/sys-auth/elogind/files/elogind-236.1-docs.patch
new file mode 100644
index 000000000000..46c6fa9b9ce6
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-236.1-docs.patch
@@ -0,0 +1,24 @@
+--- a/meson.build 2018-04-20 17:19:23.912940283 +0200
++++ b/meson.build 2018-04-20 17:20:02.265941434 +0200
+@@ -2800,20 +2800,7 @@
+ # install_data('modprobe.d/systemd.conf',
+ # install_dir : modprobedir)
+ #endif // 0
+-install_data('README',
+- 'NEWS',
+- 'CODING_STYLE',
+-#if 0 /// UNNEEDED by elogind
+-# 'DISTRO_PORTING',
+-# 'ENVIRONMENT.md',
+-#endif // 0
+- 'LICENSE.GPL2',
+- 'LICENSE.LGPL2.1',
+- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+-#if 0 /// UNNEEDED by elogind
+-# 'TRANSIENT-SETTINGS.md',
+-# 'UIDS-GIDS.md',
+-#endif // 0
++install_data('src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+ install_dir : docdir)
+
+ #if 0 /// UNNEEDED by elogind