summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-13 23:37:14 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-13 23:37:14 -0400
commit6c0c6d42aaef3f7144fffb1612e5bc056aac5aa9 (patch)
tree6e8a6ca38e42e9ab02302ecf55be0705a4718559 /sys-auth
parentapp-shells/bash: mask pre0 until newer version goes stable (diff)
downloadgentoo-6c0c6d42aaef3f7144fffb1612e5bc056aac5aa9.tar.gz
gentoo-6c0c6d42aaef3f7144fffb1612e5bc056aac5aa9.tar.bz2
gentoo-6c0c6d42aaef3f7144fffb1612e5bc056aac5aa9.zip
sys-auth/passwdqc: add a compile test for shadow.h #554504
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/passwdqc/passwdqc-1.3.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-auth/passwdqc/passwdqc-1.3.0.ebuild b/sys-auth/passwdqc/passwdqc-1.3.0.ebuild
index c7c1daee1bca..6dc27030a781 100644
--- a/sys-auth/passwdqc/passwdqc-1.3.0.ebuild
+++ b/sys-auth/passwdqc/passwdqc-1.3.0.ebuild
@@ -27,6 +27,11 @@ src_prepare() {
sed -i \
-e 's:`uname -s`:Linux:' \
Makefile || die
+ # See if the system has a shadow.h. #554504
+ echo '#include <shadow.h>' > "${T}"/test.c
+ if ! $(tc-getCPP) ${CPPFLAGS} "${T}"/test.c >& /dev/null ; then
+ sed -i -e 's:-DHAVE_SHADOW::' Makefile || die
+ fi
}
_emake() {