summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-05-16 21:15:49 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-05-16 21:15:49 +0300
commit8c524aadb2c964ca60743e93bcd098d09dcfbf65 (patch)
treef00e1455d09f2f10478fcfc0f0a3aaa899b5d93f /sys-auth
parentsys-fs/e2fsprogs: amd64 stable wrt bug #655850 (diff)
downloadgentoo-8c524aadb2c964ca60743e93bcd098d09dcfbf65.tar.gz
gentoo-8c524aadb2c964ca60743e93bcd098d09dcfbf65.tar.bz2
gentoo-8c524aadb2c964ca60743e93bcd098d09dcfbf65.zip
sys-auth/pam_p11: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_p11/Manifest1
-rw-r--r--sys-auth/pam_p11/pam_p11-0.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-auth/pam_p11/Manifest b/sys-auth/pam_p11/Manifest
index d62fd315ffed..594b4a64e46d 100644
--- a/sys-auth/pam_p11/Manifest
+++ b/sys-auth/pam_p11/Manifest
@@ -1 +1,2 @@
DIST pam_p11-0.1.6.tar.gz 351244 BLAKE2B a07f747a7abccc49e3c7bb7ceea5d4fce5c0491c2dcadfa0c5f5ce2215af724d187f00f6f1f7e43525e76f88afcf18ad74c3d38a793329e6c3175bfe696bbf3a SHA512 92ea894dfe605400dd3684b67bfb3fa4a4b6b67f0818791b492dd002063ebcf85eeb93c07d2f60ece98e579f298061c2e0c225554b6dc618bb1e335ac69f36b0
+DIST pam_p11-0.2.0.tar.gz 417550 BLAKE2B e3c5bb32d6c7c84776341796ebdb9850a9561778aee820acb2a6c61112a2a5df5ee7c539cb5974439e565046e944f4710b87c3b51dea61fdb2cd9171daac3a0c SHA512 2cadf6fe880c953554757099741f3cfe992067f251b7e7e977a6dda5f65cbe1f55b1de6d180638997eada0d3b760887091014b99f8ae4b6d31b25af8e555343c
diff --git a/sys-auth/pam_p11/pam_p11-0.2.0.ebuild b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
new file mode 100644
index 000000000000..5719fc04d4c4
--- /dev/null
+++ b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune pam
+
+DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
+HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libp11
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-pamdir="$(getpam_mod_dir)"
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}