summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zachary.medico@sony.com>2019-02-11 17:51:49 -0800
committerZac Medico <zmedico@gentoo.org>2019-02-11 17:53:56 -0800
commitdddba0c316da68b151c664e516947514d01be4b0 (patch)
tree8d9135360c62962cdc7437b36ee977ef4e03a0e9 /sys-block
parentwww-client/firefox: backport elf-hack workaround (diff)
downloadgentoo-dddba0c316da68b151c664e516947514d01be4b0.tar.gz
gentoo-dddba0c316da68b151c664e516947514d01be4b0.tar.bz2
gentoo-dddba0c316da68b151c664e516947514d01be4b0.zip
sys-block/perccli: 7.5.007.0529-r1 for bug 677770
Closes: https://bugs.gentoo.org/677770 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Copyright: Sony Interactive Entertainment Inc. Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/perccli/perccli-7.5.007.0529-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-block/perccli/perccli-7.5.007.0529-r1.ebuild b/sys-block/perccli/perccli-7.5.007.0529-r1.ebuild
new file mode 100644
index 000000000000..6c74e112c488
--- /dev/null
+++ b/sys-block/perccli/perccli-7.5.007.0529-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit mount-boot rpm
+
+DESCRIPTION="LINUX PERCCLI Utility For All Dell HBA/PERC Controllers"
+HOMEPAGE="https://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=NF8G9"
+LICENSE="Avago BSD"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="doc efi"
+RESTRICT="strip"
+DEPEND=""
+RDEPEND=""
+QA_PREBUILT="opt/MegaRAID/perccli/perccli* boot/efi/perccli.efi"
+
+DISTFILE_DOC=dell-sas-hba-12gbps_reference-guide_en-us.pdf
+
+SRC_URI="https://downloads.dell.com/FOLDER05235308M/1/perccli_linux_NF8G9_A07_7.529.00.tar.gz
+ doc? ( https://topics-cdn.dell.com/pdf/${DISTFILE_DOC} )"
+
+S="${WORKDIR}"/perccli_7.5-007.0529_linux
+
+src_unpack() {
+ default
+ cd "${S}"
+ rpm_unpack ./Linux/perccli-*.rpm
+}
+
+src_install() {
+ exeinto /opt/MegaRAID/perccli/
+ use amd64 && doexe opt/MegaRAID/perccli/perccli64 && \
+ dosym perccli64 /opt/MegaRAID/perccli/perccli
+ newexe opt/MegaRAID/perccli/perccli perccli32
+ use x86 && dosym perccli opt/MegaRAID/perccli/perccli
+ dosym ../MegaRAID/perccli/perccli /opt/bin/perccli
+ if use efi; then
+ exeinto /boot/efi/
+ doexe EFI/perccli.efi
+ fi
+ use doc && dodoc "${DISTDIR}"/${DISTFILE_DOC}
+}