summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2018-08-30 19:11:14 +1000
committerSam Jorna <wraeth@gentoo.org>2018-08-30 19:12:23 +1000
commit231fac686e1f7a78435194132c15c22738834f0e (patch)
treef4de0b34d2031e237faadbbf125cf3dd2d7a3deb /sys-boot/refind
parentsys-boot/refind: bump to 0.11.3 (diff)
downloadgentoo-231fac686e1f7a78435194132c15c22738834f0e.tar.gz
gentoo-231fac686e1f7a78435194132c15c22738834f0e.tar.bz2
gentoo-231fac686e1f7a78435194132c15c22738834f0e.zip
sys-boot/refind: remove old
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-boot/refind')
-rw-r--r--sys-boot/refind/Manifest1
-rw-r--r--sys-boot/refind/refind-0.10.8.ebuild197
2 files changed, 0 insertions, 198 deletions
diff --git a/sys-boot/refind/Manifest b/sys-boot/refind/Manifest
index a29437760673..c1bfe87d3f82 100644
--- a/sys-boot/refind/Manifest
+++ b/sys-boot/refind/Manifest
@@ -1,4 +1,3 @@
DIST refind-src-0.10.4.tar.gz 3970380 BLAKE2B 0d14c005d3e93a1f0008b6c65e34eb6391c4a4a488b4fa7842c8f0b68eb2cc5be150c8718f01a65454db7b86ffa5873a3d1a96429eaed0cb92c1d29c8d2f7dcd SHA512 a75a6210ee51427c474e69c2de8c719545b2599c19f1c7541048b77ab1996a0e4b4b5fd4840f6240cd6704e5f5338cbaff432d7dc5ec4042854e26d6df18bed5
-DIST refind-src-0.10.8.tar.gz 4059265 BLAKE2B 597d8df1cb74f6f686c5b702c02eb2712adb2076934f1ffc746ca9aaf3d349d6384c8aa09d17fe440b656cc054ee928131f8ecbc059fe0b654e9c32799e54e86 SHA512 a4576920dd68a9436ee6d008787104842e192c6a5eb52cc580258bc8e13daadf170c21270e8cfd86f27733e3e86b050af9102d35c939677b1f1c3627aeeafb32
DIST refind-src-0.11.2.tar.gz 4533034 BLAKE2B fa05781fc1d87d314677f8e670bd7282b591fd3b6f4a5863e81cb962fdb773c774faabb6c45544b0659c8d5c4ef7ce1dba8d798a4caa97364ad7aa2532a42050 SHA512 796d86f05152d93340773c2dfbae0ca50ab036373ebed60fcc80404ee269ef4bc100df4b141d555d3363b820c3e9234fc0cf637791061281c86329958dca3479
DIST refind-src-0.11.3.tar.gz 3792206 BLAKE2B 369b25dbc97d83f9143ccbe19e89b5975f0796f1e4a2decfc124e4b45c5ef1db8f3e2bb83413f596ca28e82e67b0b9c5682b557a5422e3146780cec151d2a36e SHA512 96907b79e1c9c8199c62058bb6851fa5d6f158802f3777ba19a62c6c0d7d5b49132754bcafa925510fd21c8bafe8ce393117070a628baf4c277fa5f8f536b797
diff --git a/sys-boot/refind/refind-0.10.8.ebuild b/sys-boot/refind/refind-0.10.8.ebuild
deleted file mode 100644
index 9978fe0dbf07..000000000000
--- a/sys-boot/refind/refind-0.10.8.ebuild
+++ /dev/null
@@ -1,197 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic versionator
-
-DESCRIPTION="The UEFI Boot Manager by Rod Smith"
-HOMEPAGE="https://www.rodsbooks.com/refind/"
-
-SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${PN}-src-${PV}.tar.gz"
-
-LICENSE="BSD GPL-2 GPL-3 FDL-1.3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-FS_USE="btrfs +ext2 +ext4 hfs +iso9660 ntfs reiserfs"
-IUSE="${FS_USE} -gnuefi doc -custom-cflags"
-
-DEPEND="gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
- !gnuefi? ( >=sys-boot/udk-2015 )"
-
-DOCS="NEWS.txt README.txt docs/refind docs/Styles"
-
-pkg_pretend() {
- if use custom-cflags; then
- ewarn
- ewarn "You have enabled building with USE=custom-cflags. Be aware that"
- ewarn "using this can result in EFI binaries that fail to run and may"
- ewarn "fail to build at all. This is strongly advised against by upstream."
- ewarn
- ewarn "See https://bugs.gentoo.org/598587#c3 for more information"
- ewarn
- fi
-}
-
-pkg_setup() {
- if use x86 ; then
- export EFIARCH=ia32
- export BUILDARCH=ia32
- elif use amd64; then
- export EFIARCH=x64
- export BUILDARCH=x86_64
- else
- # Try to support anyway
- export BUILDARCH=$( uname -m | sed s,i[3456789]86,ia32, )
- if [[ ${BUILDARCH} == "x86_64" ]] ; then
- export EFIARCH=x64
- else
- export EFIARCH=${ARCH}
- fi
- fi
-}
-
-src_prepare() {
- default
-
- # bug 598647 - PIE not supported
- sed -e 's:CFLAGS =:& -fno-PIE:' -i "${S}/Make.common" || die
-
- local f
- for f in "${S}"/*/Make.tiano "${S}"/Make.common; do
- sed -i -e 's/^\(include .*target.txt.*\)$/#\1/' \
- -e 's@^\(TIANO_INCLUDE_DIRS\s*=\s*-I\s*\).*$@\1/usr/include/udk \\@' \
- -e '/^\s*-I \$(EDK2BASE).*$/d' \
- "${f}" || die "Failed to patch Tianocore make file in" \
- $(basename $(dirname ${f}))
- done
- for f in "${S}"/*/Make.tiano; do
- sed -i -e 's@^\(EFILIB\s*=\s*\).*$@\1/usr/lib@' \
- -e 's@\$(EFILIB).*/\([^/]*\).lib@-l\1@' \
- -e 's/\(--start-group\s*\$(ALL_EFILIBS)\)/-L \$(EFILIB) \1/' \
- "${f}" || die "Failed to patch Tianocore make file in" \
- $(basename $(dirname ${f}))
- done
- sed -i -e '/Guids/i#include "AutoGen.h"\n' "${S}/filesystems/AutoGen.c" \
- || die "Failed to patch AutoGen.c"
- for f in "${S}"/*/AutoGen.c; do
- cat >>"${f}" <<-EOF || die "Failed to patch AutoGen.c"
-
- #define _PCD_TOKEN_PcdFixedDebugPrintErrorLevel 11U
- #define _PCD_SIZE_PcdFixedDebugPrintErrorLevel 4
- #define _PCD_GET_MODE_SIZE_PcdFixedDebugPrintErrorLevel _PCD_SIZE_PcdFixedDebugPrintErrorLevel
- #define _PCD_VALUE_PcdFixedDebugPrintErrorLevel 0xFFFFFFFFU
- GLOBAL_REMOVE_IF_UNREFERENCED const UINT32 _gPcd_FixedAtBuild_PcdFixedDebugPrintErrorLevel = _PCD_VALUE_PcdFixedDebugPrintErrorLevel;
- extern const UINT32 _gPcd_FixedAtBuild_PcdFixedDebugPrintErrorLevel;
- #define _PCD_GET_MODE_32_PcdFixedDebugPrintErrorLevel _gPcd_FixedAtBuild_PcdFixedDebugPrintErrorLevel
- //#define _PCD_SET_MODE_32_PcdFixedDebugPrintErrorLevel ASSERT(FALSE) // It is not allowed to set value for a FIXED_AT_BUILD PCD
- EOF
- done
-}
-
-src_compile() {
- # Prepare flags
- local pecoff_header_size
- [[ $EFIARCH == x64 ]] && pecoff_header_size='0x228' \
- || pecoff_header_size='0x220'
- local make_flags=(
- ARCH="${BUILDARCH}"
- GENFW="/usr/bin/GenFw"
- CC="$(tc-getCC)"
- AS="$(tc-getAS)"
- LD="$(tc-getLD)"
- AR="$(tc-getAR)"
- RANLIB="$(tc-getRANLIB)"
- OBJCOPY="$(tc-getOBJCOPY)"
- GNUEFI_LDFLAGS="-T \$(GNUEFI_LDSCRIPT) -shared -nostdlib -Bsymbolic \
- -L\$(EFILIB) -L\$(GNUEFILIB) \$(CRTOBJS) -znocombreloc -zdefs"
- TIANO_LDSCRIPT="/usr/lib/GccBase.lds"
- TIANO_LDFLAGS="-n -q --gc-sections -nostdlib \
- --script=\$(TIANO_LDSCRIPT) \
- --defsym=PECOFF_HEADER_SIZE=${pecoff_header_size} \
- --entry \$(ENTRYPOINT) -u \$(ENTRYPOINT) -m \$(LD_CODE)"
- )
-
- # Make main EFI
- local all_target
- use gnuefi && all_target="gnuefi" || all_target="tiano"
-
- if use custom-cflags; then
- emake CFLAGS="${CFLAGS}" "${make_flags[@]}" ${all_target}
- else
- emake "${make_flags[@]}" ${all_target}
- fi
-
- # Make filesystem drivers
- local gnuefi_target
- use gnuefi && gnuefi_target="_gnuefi"
- local fs
- for fs in ${FS_USE}; do
- fs=${fs#+}
- if use "${fs}"; then
- einfo "Building ${fs} filesystem driver"
- if use custom-cflags; then
- emake CFLAGS="${CFLAGS}" "${make_flags[@]}" -C "${S}/filesystems" ${fs}${gnuefi_target}
- else
- emake "${make_flags[@]}" -C "${S}/filesystems" ${fs}${gnuefi_target}
- fi
- fi
- done
-}
-
-src_install() {
- exeinto "/usr/share/${P}"
- doexe refind-install
- dosym "/usr/share/${P}/refind-install" "/usr/sbin/refind-install"
-
- dodoc "${S}"/{COPYING.txt,LICENSE.txt,CREDITS.txt}
- if use doc; then
- doman "${S}/docs/man/"*
- dodoc -r ${DOCS}
- fi
-
- insinto "/usr/share/${P}/refind"
- doins "${S}/refind/refind_${EFIARCH}.efi"
- doins "${S}/refind.conf-sample"
- doins -r images icons fonts banners
-
- if [[ -d "${S}/drivers_${EFIARCH}" ]]; then
- doins -r "${S}/drivers_${EFIARCH}"
- fi
-
- insinto "/usr/share/${P}/refind/tools_${EFIARCH}"
- doins "${S}/gptsync/gptsync_${EFIARCH}.efi"
-
- insinto "/etc/refind.d"
- doins -r "${S}/keys"
-
- dosbin "${S}/mkrlconf"
- dosbin "${S}/mvrefind"
- dosbin "${S}/refind-mkdefault"
-}
-
-pkg_postinst() {
- elog "rEFInd has been built and installed into ${EROOT%/}/usr/share/${P}"
- elog "You will need to use the command 'refind-install' to install"
- elog "the binaries into your EFI System Partition"
- elog ""
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "refind-install requires additional packages to be fully functional:"
- elog " app-crypt/sbsigntools for binary signing for use with SecureBoot"
- elog " sys-boot/efibootmgr for writing to NVRAM"
- elog " sys-block/parted for automatic ESP location and mount"
- elog ""
- elog "refind-mkdefault requires >=dev-lang/python-3"
- elog ""
- elog "A sample configuration can be found at"
- elog "${EROOT%}/usr/share/${P}/refind/refind.conf-sample"
- else
- if ! version_is_at_least "0.10.3" "${REPLACING_VERSIONS}"; then
- elog "The new refind-mkdefault script requires >=dev-lang/python-3"
- elog "to be installed"
- elog ""
- fi
- ewarn "Note that this installation will not update any EFI binaries"
- ewarn "on your EFI System Partition - this needs to be done manually"
- fi
-}