summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-20 16:11:31 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-20 16:11:41 -0400
commit4480c9a175e198a25c8cdf8a81e660bbb957c096 (patch)
treebbe05b0b2725a7d205230b8f76694a1b9959c8c4 /sys-boot/vboot-utils
parentmail-client/thunderbird: version bump to 45.0 (diff)
downloadgentoo-4480c9a175e198a25c8cdf8a81e660bbb957c096.tar.gz
gentoo-4480c9a175e198a25c8cdf8a81e660bbb957c096.tar.bz2
gentoo-4480c9a175e198a25c8cdf8a81e660bbb957c096.zip
sys-boot/vboot-utils: fix build w/newer glibc #580554
Diffstat (limited to 'sys-boot/vboot-utils')
-rw-r--r--sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch43
-rw-r--r--sys-boot/vboot-utils/vboot-utils-42_p20150219.ebuild1
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch b/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch
new file mode 100644
index 000000000000..508f54076766
--- /dev/null
+++ b/sys-boot/vboot-utils/files/vboot-utils-42_p20150219-sysmacros.patch
@@ -0,0 +1,43 @@
+https://chromium-review.googlesource.com/339680
+https://bugs.gentoo.org/580554
+
+From 7fff56afefd4e63dce2366636c084d4c1f1f95d4 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Tue, 19 Apr 2016 13:58:49 -0400
+Subject: [PATCH] include sys/sysmacros.h for major()
+
+The major() func is defined in the sys/sysmacros.h header, so include it
+explicitly for the prototype. Upstream C libs are moving away from having
+sys/types.h include it all the time implicitly.
+
+BUG=None
+TEST=precq passes
+BRANCH=None
+
+Change-Id: I56b84138f08ded2376193403f9c9db22c5f24f71
+---
+
+diff --git a/cgpt/cgpt_wrapper.c b/cgpt/cgpt_wrapper.c
+index dcfaab9..1716cdd 100644
+--- a/cgpt/cgpt_wrapper.c
++++ b/cgpt/cgpt_wrapper.c
+@@ -18,6 +18,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+
+diff --git a/futility/dump_kernel_config_lib.c b/futility/dump_kernel_config_lib.c
+index 4fe990c..abf37ae 100644
+--- a/futility/dump_kernel_config_lib.c
++++ b/futility/dump_kernel_config_lib.c
+@@ -10,6 +10,7 @@
+ #include <string.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+
diff --git a/sys-boot/vboot-utils/vboot-utils-42_p20150219.ebuild b/sys-boot/vboot-utils/vboot-utils-42_p20150219.ebuild
index 2a6b0cdb9d81..c8107944cee7 100644
--- a/sys-boot/vboot-utils/vboot-utils-42_p20150219.ebuild
+++ b/sys-boot/vboot-utils/vboot-utils-42_p20150219.ebuild
@@ -35,6 +35,7 @@ S=${WORKDIR}
src_prepare() {
epatch "${FILESDIR}"/${P}-cgpt-static.patch
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #580554
sed -i \
-e 's: -Werror : :g' \
-e 's:${DESTDIR}/\(bin\|${LIBDIR}\):${DESTDIR}/usr/\1:g' \