summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-29 17:37:40 +0100
committerJeroen Roovers <jer@gentoo.org>2017-10-29 17:41:00 +0100
commit0431ba1ff977a584ee67643036f8b98e215ff313 (patch)
tree7e1d7518a2fcb935cd6d07551e3406888929f93e /sys-boot
parentdev-lang/spark: Fix dev-ada/gnatcoll use depend (diff)
downloadgentoo-0431ba1ff977a584ee67643036f8b98e215ff313.tar.gz
gentoo-0431ba1ff977a584ee67643036f8b98e215ff313.tar.bz2
gentoo-0431ba1ff977a584ee67643036f8b98e215ff313.zip
sys-boot/unetbootin: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/Manifest1
-rw-r--r--sys-boot/unetbootin/unetbootin-657.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index b3ad8115a7e6..10818fdbb625 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -1,3 +1,4 @@
DIST unetbootin-625.tar.gz 22671470 SHA256 1c63265cbbeccfb0c45978e5235a35fcdb6f40fdd6a8b438539c1785703d05a1 SHA512 0dc672097eb857f8516208f8cbe5a0ec3229aa5dbe56108f64c415d2d9d4679a41e3f8a4b7279c511197303a2e020c95293a305de4df2dc63dc4522b3d13259b WHIRLPOOL 2444d5ca7be19d1747de641e92bb4c255c0298faac9d446eadbb3ce0b28ed7a57822c83fdebce2aaeacefa3ca0718250ca967d12e2b4fb0e4135d88f042bc93c
DIST unetbootin-647.tar.gz 16253287 SHA256 895e67366fa4b225037d7c74fc70f17932e4176fe0f784bdbb4062d5b838715f SHA512 487be195286dd1e7712afa86cb75f8a79a3acce77f5cbd2571ddad74533d84a90e17b96afecfd2c9831825975b6c562bfb218b583a042600c49a14179129e8bb WHIRLPOOL 72ab1d5598cdb4f1b456626d013bc27cd8871e301a8e36f5cfe01a3cadf6c94ccca37042641ae9fcb4a35287eed39f01a4f6e7ad115060efe279510eeaeafb41
DIST unetbootin-655.tar.gz 16258032 SHA256 4b8b565933111c5ecea84b443b40e861f828ef10e5f6bb2342ea69b77703d705 SHA512 723b4c1499b5c9afd93e5ee3803c9ca18ee5ef5f7731797eedc194a2bbcc2c5be93cc6cb1059f8514f93a8c9e6d650aec40513f649b41382ae27c2f92389d709 WHIRLPOOL fa593fddc1407ae610cca0b76e2c723481a4c6bf8e5d2e85fc73ce431504cb151488bec41815eaddbd8eb90a3e50d604d483f86d12769bf36de646aa66c7b761
+DIST unetbootin-657.tar.gz 16258176 SHA256 e091904e455aebc7b3d22d6cb3363c51796b6b9bec59389c9d4ecad54c7febee SHA512 69ffdbc23f372c795e84267dfbed2221783a7efc9b1d5f589e7c308384cdfd0d9cf0950058f665e2c10bf6f17e0efd3eff81a1bedb98da316583f2462dfed2d9 WHIRLPOOL b6ee0146f97e9c115824d8763091319457e3343326cbb173dfb218e0727df84575e576c364d1a29db96a98cce8d30a6835adda4f1d7865d5551742e2ecbfe074
diff --git a/sys-boot/unetbootin/unetbootin-657.ebuild b/sys-boot/unetbootin/unetbootin-657.ebuild
new file mode 100644
index 000000000000..453496db6670
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-657.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils qmake-utils
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="
+ ${DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-581-desktop.patch"
+)
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+}
+
+src_configure() {
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ UNBN_QTPATH="$(qt4_get_bindir)/"
+ "${UNBN_QTPATH}"lrelease ${PN}.pro || die
+
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use linguas_${lingua}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}