summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-07 09:09:38 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-07 09:25:33 +0200
commit115171d588b9df228090e33c37245cccf5c6bdda (patch)
tree12ddf559b833346cd7d9e7a0067f9daaa17cb147 /sys-boot
parentx11-terms/st: Old (diff)
downloadgentoo-115171d588b9df228090e33c37245cccf5c6bdda.tar.gz
gentoo-115171d588b9df228090e33c37245cccf5c6bdda.tar.bz2
gentoo-115171d588b9df228090e33c37245cccf5c6bdda.zip
sys-boot/palo: Version 2.11
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/files/palo-9999-toolchain.patch14
-rw-r--r--sys-boot/palo/palo-2.11.ebuild43
-rw-r--r--sys-boot/palo/palo-9999.ebuild10
4 files changed, 49 insertions, 19 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index 2895fabca7a7..aef6a7d9922b 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1 +1,2 @@
DIST palo-2.00.tar.gz 124484 BLAKE2B b46b616acf51534382f6a775b456cdcbd4771d6bc9d7a8339ad788a5c5a4a333e98a6e4815c40a6750408b1e8168a19800da11ddf7125621f77d478a651d9c75 SHA512 b6dab81e6c2641a64a40561a65b5412ee702136ac79dab94619e0094faf011e158c67e681f45d5aa51423f5f162da7c1fd07b391b58e8a2100e1306eb7148056
+DIST palo-2.11.tar.gz 129144 BLAKE2B 25ea9462e7a87da333ace52be624aab65cc1fa4d20848bdec4ba1cea468b3ecd850dd7ceb936e9f2bd5761add766df65d054dc1b5d3f9cee991e9b3e4ddf864a SHA512 26e989ce0c652d6fafdc98d3ab3564d4adc5c943e3d44b0275beb8c385ad52cad0a29ad360e4992fb35c0f2036e29d3eee9b8f6594a53eaea9c3b973a60d9029
diff --git a/sys-boot/palo/files/palo-9999-toolchain.patch b/sys-boot/palo/files/palo-9999-toolchain.patch
deleted file mode 100644
index 4869f7e6a4e4..000000000000
--- a/sys-boot/palo/files/palo-9999-toolchain.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/palo/Makefile
-+++ b/palo/Makefile
-@@ -10,9 +10,9 @@
- OS := $(shell uname -s)
- CC?=cc
- ifeq ($(strip ${OS}),HP-UX)
--CFLAGS=-g -O -I../include -I../lib -I$(PA)/include
-+CFLAGS=-O -I../include -I../lib -I$(PA)/include
- else
--CFLAGS=-g -O -I../include -I../lib -D_FILE_OFFSET_BITS=64
-+CFLAGS=-O -I../include -I../lib -D_FILE_OFFSET_BITS=64
- endif
-
- ifneq ("$(wildcard /etc/debian_version)","")
diff --git a/sys-boot/palo/palo-2.11.ebuild b/sys-boot/palo/palo-2.11.ebuild
new file mode 100644
index 000000000000..cf05c9a92a79
--- /dev/null
+++ b/sys-boot/palo/palo-2.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}
diff --git a/sys-boot/palo/palo-9999.ebuild b/sys-boot/palo/palo-9999.ebuild
index 7800f7b0c900..c7ae9c107e1b 100644
--- a/sys-boot/palo/palo-9999.ebuild
+++ b/sys-boot/palo/palo-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic git-r3 toolchain-funcs
+inherit git-r3 toolchain-funcs
DESCRIPTION="PALO : PArisc Linux Loader"
HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS=""
PATCHES=(
- "${FILESDIR}"/${PN}-9999-toolchain.patch
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
)
src_prepare() {
@@ -32,6 +32,9 @@ src_install() {
into /
dosbin palo/palo
+ insinto /usr/share/palo
+ doins iplboot
+
insinto /etc
doins "${FILESDIR}"/palo.conf
@@ -42,7 +45,4 @@ src_install() {
doman palo.8
dodoc TODO debian/changelog README.html
-
- insinto /usr/share/palo
- doins iplboot
}