summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-26 13:14:48 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-26 13:14:48 +0800
commit1c5ce3b9f9d90010f9941cabfaafdbdb6f9e72ad (patch)
treef971d4e1573cf88cfc40743c6917d634e82d4bbf /sys-boot
parentapp-emulation/wine: restrict gcc-5 only for 64-bit wine (diff)
downloadgentoo-1c5ce3b9f9d90010f9941cabfaafdbdb6f9e72ad.tar.gz
gentoo-1c5ce3b9f9d90010f9941cabfaafdbdb6f9e72ad.tar.bz2
gentoo-1c5ce3b9f9d90010f9941cabfaafdbdb6f9e72ad.zip
sys-boot/refind: substitute with final ebuild, rm bogus file
Package-Manager: portage-2.2.20
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/refind-0.9.0.ebuild31
-rw-r--r--sys-boot/refind/thiisthing0
2 files changed, 17 insertions, 14 deletions
diff --git a/sys-boot/refind/refind-0.9.0.ebuild b/sys-boot/refind/refind-0.9.0.ebuild
index 2b763a70982e..d3b517b67bc0 100644
--- a/sys-boot/refind/refind-0.9.0.ebuild
+++ b/sys-boot/refind/refind-0.9.0.ebuild
@@ -13,26 +13,28 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="btrfs +ext2 +ext4 hfs +iso9660 ntfs reiserfs"
-DOCS="BUILDING.txt NEWS.txt README.txt refind.conf-sample {refind,Styles}"
+DOCS="NEWS.txt README.txt refind.conf-sample docs/refind docs/Styles"
DEPEND=">=sys-boot/gnu-efi-3.0u"
RDEPEND=""
src_compile() {
- emake gnuefi || die "Failed to build refind EFI binary"
+ emake gnuefi
- cd "${S}/filesystems"
- for fs in ext2 ext4 reiserfs iso9660 hfs btrfs ; do
- if use "${fs}" ; then
+ pushd "${S}/filesystems" > /dev/null
+ for fs in ${IUSE}; do
+ fs=${fs#+}
+ if use "${fs}"; then
einfo "Building ${fs} filesystem driver"
rm -f fsw_efi.o
# ARCH detection in the Makefile not working
use x86 && buildarch=ia32
use amd64 && buildarch=x86_64
- emake DRIVERNAME=${fs} ARCH=${buildarch} -f Make.gnuefi || die "Failed building ${fs} filesystem EFI binary"
+ emake DRIVERNAME=${fs} ARCH=${buildarch} -f Make.gnuefi
fi
done
+ popd > /dev/null
}
src_install() {
@@ -48,14 +50,15 @@ src_install() {
use x86 && filearch=ia32
use amd64 && filearch=x64
insinto "/usr/share/${P}/refind/drivers_${filearch}"
- for fs in ext2 ext4 reiserfs iso9660 hfs btrfs ; do
- if use "${fs}" ; then doins "drivers_${filearch}/${fs}_${filearch}.efi" ; fi
+ for fs in ${IUSE}; do
+ fs=${fs#+}
+ if use "${fs}"; then
+ doins "drivers_${filearch}/${fs}_${filearch}.efi"
+ fi
done
- for dir in images icons fonts banners ; do
- insinto "/usr/share/${P}/refind/${dir}"
- doins -r "${dir}"
- done
+ insinto "/usr/share/${P}/refind"
+ doins -r images icons fonts banners
insinto "/usr/share/${P}/keys"
doins keys/*
@@ -65,10 +68,10 @@ pkg_postinst() {
einfo ""
einfo "EFI executables have been built and installed into /usr/share/${P}"
einfo "You will need to use the provided install script 'install.sh' or"
- einfo "manually install the binaries into your EFI System Partition."
+ einfo "manually install the binaries into your EFI System Partition"
einfo ""
einfo "For key generation and binary signing for use with SecureBoot, the"
- einfo "package app-crypt/sbsigntool can be installed."
+ einfo "package app-crypt/sbsigntool can be installed"
einfo ""
einfo "A sample configration can be found at"
einfo "/usr/share/doc/${P}/refind.conf-sample.bz2"
diff --git a/sys-boot/refind/thiisthing b/sys-boot/refind/thiisthing
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/sys-boot/refind/thiisthing
+++ /dev/null