summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-06-09 18:11:57 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-06-09 18:12:52 +0200
commit2c743a1c520e5ecf2793d63a2715b0f6fe7f7287 (patch)
treefde13c68331fe1f6f3943a65179b30c4a56cdaf7 /sys-boot
parentvirtual/pypy: Add 5.3.0 (diff)
downloadgentoo-2c743a1c520e5ecf2793d63a2715b0f6fe7f7287.tar.gz
gentoo-2c743a1c520e5ecf2793d63a2715b0f6fe7f7287.tar.bz2
gentoo-2c743a1c520e5ecf2793d63a2715b0f6fe7f7287.zip
sys-boot/syslinux: fix quoting for toolchain functions
Bug: https://bugs.gentoo.org/show_bug.cgi?id=585186 Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/syslinux-3.86.ebuild4
-rw-r--r--sys-boot/syslinux/syslinux-4.07.ebuild4
-rw-r--r--sys-boot/syslinux/syslinux-5.10.ebuild4
-rw-r--r--sys-boot/syslinux/syslinux-6.03.ebuild6
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1.ebuild6
5 files changed, 12 insertions, 12 deletions
diff --git a/sys-boot/syslinux/syslinux-3.86.ebuild b/sys-boot/syslinux/syslinux-3.86.ebuild
index 79187cc0a5af..740c4e6fc85b 100644
--- a/sys-boot/syslinux/syslinux-3.86.ebuild
+++ b/sys-boot/syslinux/syslinux-3.86.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -47,7 +47,7 @@ src_unpack() {
}
src_compile() {
- emake CC=$(tc-getCC) installer || die
+ emake CC="$(tc-getCC)" installer || die
}
src_install() {
diff --git a/sys-boot/syslinux/syslinux-4.07.ebuild b/sys-boot/syslinux/syslinux-4.07.ebuild
index 05495b34a98a..8bfd278585d4 100644
--- a/sys-boot/syslinux/syslinux-4.07.ebuild
+++ b/sys-boot/syslinux/syslinux-4.07.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -60,7 +60,7 @@ src_unpack() {
}
src_compile() {
- emake CC=$(tc-getCC) installer || die
+ emake CC="$(tc-getCC)" installer || die
}
src_install() {
diff --git a/sys-boot/syslinux/syslinux-5.10.ebuild b/sys-boot/syslinux/syslinux-5.10.ebuild
index 90f43652cfbf..00c3a4890c1c 100644
--- a/sys-boot/syslinux/syslinux-5.10.ebuild
+++ b/sys-boot/syslinux/syslinux-5.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -63,7 +63,7 @@ src_prepare() {
}
src_compile() {
- emake CC=$(tc-getCC) installer
+ emake CC="$(tc-getCC)" installer
}
src_install() {
diff --git a/sys-boot/syslinux/syslinux-6.03.ebuild b/sys-boot/syslinux/syslinux-6.03.ebuild
index fe34dc6eb086..c4d25db475d7 100644
--- a/sys-boot/syslinux/syslinux-6.03.ebuild
+++ b/sys-boot/syslinux/syslinux-6.03.ebuild
@@ -89,15 +89,15 @@ src_compile() {
# build system abuses the LDFLAGS variable to pass arguments to ld
unset LDFLAGS
if [[ ! -z ${loaderarch} ]]; then
- emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch}
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch}
fi
- emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch} installer
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch} installer
}
src_install() {
# parallel install fails sometimes
einfo "loaderarch=${loaderarch}"
- emake -j1 LD=$(tc-getLD) INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
+ emake -j1 LD="$(tc-getLD)" INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
dodoc README NEWS doc/*.txt
}
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1.ebuild
index fe34dc6eb086..c4d25db475d7 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1.ebuild
@@ -89,15 +89,15 @@ src_compile() {
# build system abuses the LDFLAGS variable to pass arguments to ld
unset LDFLAGS
if [[ ! -z ${loaderarch} ]]; then
- emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch}
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch}
fi
- emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch} installer
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch} installer
}
src_install() {
# parallel install fails sometimes
einfo "loaderarch=${loaderarch}"
- emake -j1 LD=$(tc-getLD) INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
+ emake -j1 LD="$(tc-getLD)" INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
dodoc README NEWS doc/*.txt
}