summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-31 11:24:21 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-31 22:48:45 +0100
commit2df3277cb07eb3cddca3d3280a256394fb069e93 (patch)
treec1738e736bfc8b0b4536b842eaf0d0c8abfd17a3 /sys-boot
parentsys-boot/grub: Drop interim old version (redudant) (diff)
downloadgentoo-2df3277cb07eb3cddca3d3280a256394fb069e93.tar.gz
gentoo-2df3277cb07eb3cddca3d3280a256394fb069e93.tar.bz2
gentoo-2df3277cb07eb3cddca3d3280a256394fb069e93.zip
sys-boot/grub: Stop using awful multijob_* logic
The multijob logic adds a lot of complex, unmaintained and fragile bash code with little gain. Moreover, makes build logs unreadable by interspersing output from multiple configure runs. Bug: https://bugs.gentoo.org/613322
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-0.97-r16.ebuild10
-rw-r--r--sys-boot/grub/grub-0.97-r18.ebuild10
2 files changed, 2 insertions, 18 deletions
diff --git a/sys-boot/grub/grub-0.97-r16.ebuild b/sys-boot/grub/grub-0.97-r16.ebuild
index 06d9aa23b124..22793c03ab03 100644
--- a/sys-boot/grub/grub-0.97-r16.ebuild
+++ b/sys-boot/grub/grub-0.97-r16.ebuild
@@ -17,7 +17,7 @@
EAPI="5"
-inherit eutils mount-boot toolchain-funcs linux-info flag-o-matic autotools pax-utils multiprocessing
+inherit eutils mount-boot toolchain-funcs linux-info flag-o-matic autotools pax-utils
PATCHVER="1.14" # Should match the revision ideally
DESCRIPTION="GNU GRUB Legacy boot loader"
@@ -121,12 +121,8 @@ src_configure() {
fi
fi
- multijob_init
-
# build the net-bootable grub first, but only if "netboot" is set
if use netboot ; then
- (
- multijob_child_init
mkdir -p "${WORKDIR}"/netboot
pushd "${WORKDIR}"/netboot >/dev/null
ECONF_SOURCE=${S} \
@@ -141,8 +137,6 @@ src_configure() {
--enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
--enable-{tulip,via-rhine,w89c840}
popd >/dev/null
- ) &
- multijob_post_fork
fi
# Now build the regular grub
@@ -156,8 +150,6 @@ src_configure() {
# sanity check due to common failure
use ncurses && ! grep -qs "HAVE_LIBCURSES.*1" config.h && die "USE=ncurses but curses not found"
-
- multijob_finish
}
src_compile() {
diff --git a/sys-boot/grub/grub-0.97-r18.ebuild b/sys-boot/grub/grub-0.97-r18.ebuild
index eb8206061434..9d5aeede6898 100644
--- a/sys-boot/grub/grub-0.97-r18.ebuild
+++ b/sys-boot/grub/grub-0.97-r18.ebuild
@@ -17,7 +17,7 @@
EAPI="6"
-inherit eutils mount-boot toolchain-funcs linux-info flag-o-matic autotools pax-utils multiprocessing
+inherit eutils mount-boot toolchain-funcs linux-info flag-o-matic autotools pax-utils
PATCHVER="1.15" # Should match the revision ideally
DESCRIPTION="GNU GRUB Legacy boot loader"
@@ -121,12 +121,8 @@ src_configure() {
fi
fi
- multijob_init
-
# build the net-bootable grub first, but only if "netboot" is set
if use netboot ; then
- (
- multijob_child_init
mkdir -p "${WORKDIR}"/netboot
pushd "${WORKDIR}"/netboot >/dev/null
ECONF_SOURCE=${S} \
@@ -141,8 +137,6 @@ src_configure() {
--enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
--enable-{tulip,via-rhine,w89c840}
popd >/dev/null
- ) &
- multijob_post_fork
fi
# Now build the regular grub
@@ -156,8 +150,6 @@ src_configure() {
# sanity check due to common failure
use ncurses && ! grep -qs "HAVE_LIBCURSES.*1" config.h && die "USE=ncurses but curses not found"
-
- multijob_finish
}
src_compile() {