summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-07-02 11:37:41 -0400
committerMike Gilbert <floppym@gentoo.org>2017-07-02 11:37:41 -0400
commitbc66500710ec040ef242342447694d91f1ffa8f0 (patch)
treead21ebfdbfe1fef95fbf09e4ed0b3e774c263a25 /sys-boot
parentsys-boot/systemd-boot: restrict test (diff)
downloadgentoo-bc66500710ec040ef242342447694d91f1ffa8f0.tar.gz
gentoo-bc66500710ec040ef242342447694d91f1ffa8f0.tar.bz2
gentoo-bc66500710ec040ef242342447694d91f1ffa8f0.zip
sys-boot/systemd-boot: remove old
Package-Manager: Portage-2.3.6_p9, Repoman-2.3.2_p77
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/systemd-boot/Manifest2
-rw-r--r--sys-boot/systemd-boot/systemd-boot-231-r1.ebuild125
-rw-r--r--sys-boot/systemd-boot/systemd-boot-232.ebuild114
3 files changed, 0 insertions, 241 deletions
diff --git a/sys-boot/systemd-boot/Manifest b/sys-boot/systemd-boot/Manifest
index 71c131fed62c..5848388fa133 100644
--- a/sys-boot/systemd-boot/Manifest
+++ b/sys-boot/systemd-boot/Manifest
@@ -1,3 +1 @@
-DIST systemd-231.tar.gz 4381464 SHA256 899733ad6c157cedbb89aec4efe3bc824dcfd65a1d6f6bebc7b043f7924e39b4 SHA512 199fa33a0494d1d15f7fe3c796fe14913ad386766571d4d3fbb1cb1c446e04f6d06a965213be4c594a7183e810fc2fd4804fe14f64f21b0a1278b717889811c6 WHIRLPOOL 7779291e9fb9873cb1773b8583cf6d4b7dec837363ea89c4a73c1e397a76752b66f8b57d8fc4d9cef768cc1855b5e325ad88a8a69eb5380aa924e0a6dead41b1
-DIST systemd-232.tar.gz 4529048 SHA256 1172c7c7d5d72fbded53186e7599d5272231f04cc8b72f9a0fb2c5c20dfc4880 SHA512 5dbe52f655ec2901b1bfbb1256f83ba26bc82c13097ac9a82e4fbb97886551530f9888c369592f1b410cfff40d6d127b985533a3e29cfab5b30d18739ee5dcb1 WHIRLPOOL f2a1499584c5b5c4d9e945e45ef5e0eef2e8be77acdbd7b3b29a8c8b62dc7a10c162a856df7107c19e2eb19e63bc43a33433686472ca30909237981683cbe980
DIST systemd-233.tar.gz 4660737 SHA256 8b3e99da3d4164b66581830a7f2436c0c8fe697b5fbdc3927bdb960646be0083 SHA512 5ad5329ea116d973cf67096f7e7ad28e9ea0905696e9451291f1d25e5064f4a9bfcfae87e912996c6a38397e9f4a148d4ccecfa9b70f7ecdf04deadb61784c8e WHIRLPOOL ce19f6a546b8f899cfa952e49d47f063fd29186be4a53391bc30ea2c487eb2c140a74ad843a1dc499bb61bba3e9ca055613852291e38b85af5d79c59409dc176
diff --git a/sys-boot/systemd-boot/systemd-boot-231-r1.ebuild b/sys-boot/systemd-boot/systemd-boot-231-r1.ebuild
deleted file mode 100644
index 3fe25b2193bd..000000000000
--- a/sys-boot/systemd-boot/systemd-boot-231-r1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils toolchain-funcs
-
-DESCRIPTION="UEFI boot manager from systemd (formerly gummiboot)"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/"
-SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-COMMON_DEPEND="
- >=sys-apps/util-linux-2.27.1:0=
- sys-libs/libcap:=
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.2
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt:0
- >=dev-util/intltool-0.50
- >=sys-boot/gnu-efi-3.0.2
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-apps/systemd
-"
-
-S="${WORKDIR}/systemd-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/232-0002-build-sys-add-check-for-gperf-lookup-function-signat.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- EFI_CC="$(tc-getPROG "EFI_CC CC" gcc)"
- cc_cv_CFLAGS__flto=no
- cc_cv_LDFLAGS__Wl__fuse_ld_gold=no
- --enable-blkid
- --enable-efi
- --enable-gnuefi
- --disable-acl
- --disable-apparmor
- --disable-audit
- --disable-bzip2
- --disable-elfutils
- --disable-gcrypt
- --disable-gnutls
- --disable-kmod
- --disable-libcryptsetup
- --disable-libcurl
- --disable-libidn
- --disable-lz4
- --disable-microhttpd
- --disable-myhostname
- --disable-pam
- --disable-qrencode
- --disable-seccomp
- --disable-selinux
- --disable-xkbcommon
- --disable-xz
- --disable-zlib
- )
- econf "${myeconfargs[@]}"
-}
-
-efi-mt() {
- case "$(tc-arch)" in
- amd64) echo x64 ;;
- arm64) echo aa64 ;;
- x86) echo ia32 ;;
- *) die "Unsupported arch" ;;
- esac
-}
-
-src_compile() {
- local args=(
- libsystemd-shared.la
- bootctl
- man/bootctl.1
- man/kernel-install.8
- linux$(efi-mt).efi.stub
- systemd-boot$(efi-mt).efi
- )
- emake built-sources
- emake "${args[@]}"
-}
-
-src_install() {
- local args=(
- DESTDIR="${D%/}"
-
- # libsystemd-shared
- rootlibexec_LTLIBRARIES=libsystemd-shared.la
- install-rootlibexecLTLIBRARIES
-
- # bootctl
- lib_LTLIBRARIES=
- bin_PROGRAMS=bootctl
- install-binPROGRAMS
-
- # kernel-install
- install-dist_binSCRIPTS
- install-dist_kernelinstallSCRIPTS
-
- man_MANS="man/bootctl.1 man/kernel-install.8"
- install-man1
- install-man8
-
- install-bootlibDATA
- )
- emake "${args[@]}"
- prune_libtool_files
- einstalldocs
-}
diff --git a/sys-boot/systemd-boot/systemd-boot-232.ebuild b/sys-boot/systemd-boot/systemd-boot-232.ebuild
deleted file mode 100644
index 11a9e7452899..000000000000
--- a/sys-boot/systemd-boot/systemd-boot-232.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils toolchain-funcs
-
-DESCRIPTION="UEFI boot manager from systemd (formerly gummiboot)"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/"
-SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-COMMON_DEPEND="
- >=sys-apps/util-linux-2.27.1:0=
- sys-libs/libcap:=
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.2
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt:0
- >=dev-util/intltool-0.50
- >=sys-boot/gnu-efi-3.0.2
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-apps/systemd
-"
-
-S="${WORKDIR}/systemd-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/232-0002-build-sys-add-check-for-gperf-lookup-function-signat.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- EFI_CC="$(tc-getPROG "EFI_CC CC" gcc)"
- cc_cv_CFLAGS__flto=no
- cc_cv_LDFLAGS__Wl__fuse_ld_gold=no
- --enable-blkid
- --enable-efi
- --enable-gnuefi
- --disable-acl
- --disable-apparmor
- --disable-audit
- --disable-bzip2
- --disable-elfutils
- --disable-gcrypt
- --disable-gnutls
- --disable-kmod
- --disable-libcryptsetup
- --disable-libcurl
- --disable-libidn
- --disable-lz4
- --disable-microhttpd
- --disable-myhostname
- --disable-pam
- --disable-qrencode
- --disable-seccomp
- --disable-selinux
- --disable-xkbcommon
- --disable-xz
- --disable-zlib
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- local targets=(
- libsystemd-shared.la
- bootctl
- man/bootctl.1
- man/kernel-install.8
- '$(bootlib_DATA)'
- )
- emake built-sources
- echo "gentoo: ${targets[*]}" | emake -f Makefile -f - gentoo
-}
-
-src_install() {
- local args=(
- DESTDIR="${D%/}"
-
- # libsystemd-shared
- rootlibexec_LTLIBRARIES=libsystemd-shared.la
- install-rootlibexecLTLIBRARIES
-
- # bootctl
- bin_PROGRAMS=bootctl
- install-binPROGRAMS
-
- # kernel-install
- install-dist_binSCRIPTS
- install-dist_kernelinstallSCRIPTS
-
- man_MANS="man/bootctl.1 man/kernel-install.8"
- install-man1
- install-man8
-
- install-bootlibDATA
- )
- emake "${args[@]}"
- prune_libtool_files
- einstalldocs
-}