summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-10-18 15:08:30 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-10-18 15:08:38 +0100
commitbe93c5b3dd8972e46578c6d3532d3e50e4b1283f (patch)
treefa9ac6070124baa3df48ac772795eff0b87510f1 /sys-boot
parentwww-client/chromium: stable channel bump (62.0.3202.62) (diff)
downloadgentoo-be93c5b3dd8972e46578c6d3532d3e50e4b1283f.tar.gz
gentoo-be93c5b3dd8972e46578c6d3532d3e50e4b1283f.tar.bz2
gentoo-be93c5b3dd8972e46578c6d3532d3e50e4b1283f.zip
sys-boot/aboot: add basic cross-compilation support
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild7
-rw-r--r--sys-boot/aboot/files/aboot-respect-AR.patch13
2 files changed, 17 insertions, 3 deletions
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
index 9fcd14b1d0ff..ba13f7c301bc 100644
--- a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
+++ b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils
+inherit eutils toolchain-funcs
KERN_VER="2.6.22"
@@ -33,6 +33,7 @@ src_unpack() {
epatch "${FILESDIR}/aboot-pt_note.patch"
# Bug 364697
epatch "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
+ epatch "${FILESDIR}"/aboot-respect-AR.patch
# Modified patch from Debian to add netboot support
epatch "${WORKDIR}"/aboot_gentoo.diff
@@ -40,7 +41,7 @@ src_unpack() {
src_compile() {
# too many problems with parallel building
- emake -j1 || die "emake failed"
+ emake -j1 AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) || die "emake failed"
}
src_install() {
diff --git a/sys-boot/aboot/files/aboot-respect-AR.patch b/sys-boot/aboot/files/aboot-respect-AR.patch
new file mode 100644
index 000000000000..44e4a2a52063
--- /dev/null
+++ b/sys-boot/aboot/files/aboot-respect-AR.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/Makefile b/lib/Makefile
+index e3a2247..c137b53 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -13,6 +13,6 @@ libaboot.a: vsprintf.o memcpy.o memset.o string.o _setjmp.o \
+ __remlu.o
+- ar cru $@ $?
++ $(AR) cru $@ $?
+ else
+ libaboot.a: isolib.o
+- ar cru $@ $?
++ $(AR) cru $@ $?
+ endif