summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-10 10:52:21 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-10 10:52:21 +0200
commitc02c63687ee8909a0dd375fe9a5c96a24cc73189 (patch)
treefacd14cba5c298537eac8d131c1b86d472c4d29d /sys-boot
parentsys-boot/palo: Fix toolchain patch. (diff)
downloadgentoo-c02c63687ee8909a0dd375fe9a5c96a24cc73189.tar.gz
gentoo-c02c63687ee8909a0dd375fe9a5c96a24cc73189.tar.bz2
gentoo-c02c63687ee8909a0dd375fe9a5c96a24cc73189.zip
sys-boot/palo: Update live ebuild.
Package-Manager: portage-2.3.1
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/palo-9999.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/sys-boot/palo/palo-9999.ebuild b/sys-boot/palo/palo-9999.ebuild
index b9aa701403b4..cbc7d4680e59 100644
--- a/sys-boot/palo/palo-9999.ebuild
+++ b/sys-boot/palo/palo-9999.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
+EAPI=6
inherit eutils flag-o-matic git-r3 toolchain-funcs
DESCRIPTION="PALO : PArisc Linux Loader"
@@ -14,15 +13,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-toolchain.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-9999-toolchain.patch
+ default
sed -i lib/common.h -e '/^#define PALOVERSION/{s|".*"|"'${PV}'"|g}' || die
}
src_compile() {
- emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) \
- makepalo makeipl || die
- emake CC=$(tc-getCC) iplboot || die
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
}
src_install() {
@@ -30,8 +34,7 @@ src_install() {
dosbin palo/palo
doman palo.8
- dodoc palo.conf
- dohtml README.html
+ dodoc TODO debian/changelog README.html
insinto /etc
doins "${FILESDIR}"/palo.conf