summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-10-14 12:03:42 -0700
committerPatrick McLean <chutzpah@gentoo.org>2016-10-14 12:03:42 -0700
commit85131640bbbc50c7d19cb56e2b45dff8f680548d (patch)
tree058dad744018fbc96a72f1792f31c0375384e068 /sys-cluster
parentsci-astronomy/stellarium: Version bump to 15.0 and EAPI bump 5 -> 6 (diff)
downloadgentoo-85131640bbbc50c7d19cb56e2b45dff8f680548d.tar.gz
gentoo-85131640bbbc50c7d19cb56e2b45dff8f680548d.tar.bz2
gentoo-85131640bbbc50c7d19cb56e2b45dff8f680548d.zip
sys-cluster/ceph: Allow setting the UID and GID for the ceph user
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-10.2.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-cluster/ceph/ceph-10.2.3.ebuild b/sys-cluster/ceph/ceph-10.2.3.ebuild
index 9027cfb4e098..6fd74abba2b4 100644
--- a/sys-cluster/ceph/ceph-10.2.3.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.3.ebuild
@@ -130,8 +130,8 @@ check-reqs_export_vars() {
}
user_setup() {
- enewgroup ceph
- enewuser ceph -1 -1 /var/lib/ceph ceph
+ enewgroup ceph ${CEPH_GID}
+ enewuser ceph "${CEPH_UID:--1}" -1 /var/lib/ceph ceph
}
emake_python_bindings() {