summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-06 09:40:27 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-06 14:47:55 +0200
commit3dc2033249469ce893abcd73164058280fbaae95 (patch)
treec6867b2c034d7f8227c293f7710fcdac113c9981 /sys-devel/clang/clang-9999.ebuild
parentsys-devel/clang: Fix compressing manpages (diff)
downloadgentoo-3dc2033249469ce893abcd73164058280fbaae95.tar.gz
gentoo-3dc2033249469ce893abcd73164058280fbaae95.tar.bz2
gentoo-3dc2033249469ce893abcd73164058280fbaae95.zip
sys-devel/clang: Fix installing extra tool docs to docdir
Diffstat (limited to 'sys-devel/clang/clang-9999.ebuild')
-rw-r--r--sys-devel/clang/clang-9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 03ed29156ba4..cd95492a02c5 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -184,6 +184,7 @@ multilib_src_configure() {
)
use doc && mycmakeargs+=(
-DCLANG_INSTALL_SPHINX_HTML_DIR="${EPREFIX}/usr/share/doc/${PF}/html"
+ -DCLANG-TOOLS_INSTALL_SPHINX_HTML_DIR="${EPREFIX}/usr/share/doc/${PF}/tools-extra"
-DSPHINX_WARNINGS_AS_ERRORS=OFF
)
else
@@ -290,4 +291,6 @@ multilib_src_install_all() {
fi
docompress "/usr/lib/llvm/${SLOT}/share/man"
+ # match 'html' non-compression
+ use doc && docompress -x "/usr/share/doc/${PF}/tools-extra"
}