summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-01 00:25:55 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-01 00:29:19 +0100
commit871a6adcce9514e05f1d5074c337c0684c932c2b (patch)
tree2b8ef80332ad2d855111bf5316bbd4d51dce6e03 /sys-devel/clang/clang-9999.ebuild
parentdev-util/lldb: Introduce the initial live version (diff)
downloadgentoo-871a6adcce9514e05f1d5074c337c0684c932c2b.tar.gz
gentoo-871a6adcce9514e05f1d5074c337c0684c932c2b.tar.bz2
gentoo-871a6adcce9514e05f1d5074c337c0684c932c2b.zip
sys-devel/clang: Stop overriding incorrect LLVMgold.so location
Remove the patch allowing override of LLVMgold.so libdir, and the relevant override. The patch has been rejected upstream, and the case of running non-native driver considered not important enough to deserve the added complexity. I will attempt to find another (upstreamable) solution.
Diffstat (limited to 'sys-devel/clang/clang-9999.ebuild')
-rw-r--r--sys-devel/clang/clang-9999.ebuild7
1 files changed, 0 insertions, 7 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 6a09eb1c944d..689eaae5b47d 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -117,16 +117,11 @@ src_prepare() {
# support overriding clang runtime install directory
eapply "${FILESDIR}"/9999/0005-cmake-Supporting-overriding-runtime-libdir-via-CLANG.patch
- # support overriding LLVMgold.so plugin directory
- eapply "${FILESDIR}"/9999/0006-cmake-Add-CLANG_GOLD_LIBDIR_SUFFIX-to-specify-loc-of.patch
# fix stand-alone doc build
eapply "${FILESDIR}"/9999/0007-cmake-Support-stand-alone-Sphinx-doxygen-doc-build.patch
# User patches
eapply_user
-
- # Native libdir is used to hold LLVMgold.so
- NATIVE_LIBDIR=$(get_libdir)
}
multilib_src_configure() {
@@ -135,8 +130,6 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
# install clang runtime straight into /usr/lib
-DCLANG_LIBDIR_SUFFIX=""
- # specify host's binutils gold plugin path
- -DCLANG_GOLD_LIBDIR_SUFFIX="${NATIVE_LIBDIR#lib}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"