summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-02 09:47:28 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-02 09:57:53 +0200
commitdaff852655b93c8bc44c71b3c14184b4c3bbf1f2 (patch)
treef50dae0301d27313c0ac830d4ab4c60899c468ba /sys-devel
parentapp-admin/denyhosts: Stable for HPPA (bug #571536). (diff)
downloadgentoo-daff852655b93c8bc44c71b3c14184b4c3bbf1f2.tar.gz
gentoo-daff852655b93c8bc44c71b3c14184b4c3bbf1f2.tar.bz2
gentoo-daff852655b93c8bc44c71b3c14184b4c3bbf1f2.zip
sys-devel/clang: Use target symlinks instead of wrappers
Create symlinks for ABI targets instead of wrappers since clang already processes target prefixes in argv[0].
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/clang-9999.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index cedfc02923f9..adca5ce8a787 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -231,16 +231,12 @@ src_install() {
dosym "${i}-${clang_version}" "/usr/bin/${i}"
done
- # now create wrappers for all supported ABIs
+ # now create target symlinks for all supported ABIs
for abi in $(get_all_abis); do
- local abi_flags=$(get_abi_CFLAGS "${abi}")
local abi_chost=$(get_abi_CHOST "${abi}")
for i in "${clang_tools[@]}"; do
- cat > "${T}"/wrapper.tmp <<-_EOF_ || die
- #!${EPREFIX}/bin/sh
- exec "${i}-${clang_version}" ${abi_flags} "\${@}"
- _EOF_
- newbin "${T}"/wrapper.tmp "${abi_chost}-${i}-${clang_version}"
+ dosym "${i}-${clang_version}" \
+ "/usr/bin/${abi_chost}-${i}-${clang_version}"
dosym "${abi_chost}-${i}-${clang_version}" \
"/usr/bin/${abi_chost}-${i}"
done