summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2016-06-29 17:17:07 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2016-06-30 01:31:15 +0300
commit78687b7871a6d19ba23ac5da91c72d9732061bc1 (patch)
treebefa090ead56292b47a1607c1388583318fbbc3e /sys-fabric/infinipath-psm
parentgames-emulation/dosbox: sync live ebuild and make it copyable (diff)
downloadgentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.tar.gz
gentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.tar.bz2
gentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.zip
eclass/openib.eclass: Clean up ancient versions
Also move to sys-fabric category
Diffstat (limited to 'sys-fabric/infinipath-psm')
-rw-r--r--sys-fabric/infinipath-psm/Manifest2
-rw-r--r--sys-fabric/infinipath-psm/files/42-infinipath-psm.rules2
-rw-r--r--sys-fabric/infinipath-psm/files/infinipath-psm-include.patch10
-rw-r--r--sys-fabric/infinipath-psm/infinipath-psm-3.0.1.ebuild37
-rw-r--r--sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild36
-rw-r--r--sys-fabric/infinipath-psm/metadata.xml8
6 files changed, 95 insertions, 0 deletions
diff --git a/sys-fabric/infinipath-psm/Manifest b/sys-fabric/infinipath-psm/Manifest
new file mode 100644
index 000000000000..ca457c585395
--- /dev/null
+++ b/sys-fabric/infinipath-psm/Manifest
@@ -0,0 +1,2 @@
+DIST OFED-3.12-rc1.tgz 22055476 SHA256 14ca8a2b0d68e3ee9a37f475fa9eecd9a5ffd6055135f9d4d9db8319843a94dc SHA512 9f834d6982ab7e8ab47a8b5c958ab2e4c238ef983e47798e7f06655f69672ea1e996297939b381f26ed8c39552f6e62156173d5ddd2f0a7b6cad6aecdd973944 WHIRLPOOL 5a64b1d952890ea0e72e0ca93654a0fabc8f871475b05fcbe3b214ddfe4836f6b92d4fbc9e0f0d79acfe69d8c8d219b2c467c23654021e23eaf85ae6825ea4a9
+DIST OFED-3.5-rc2.tgz 18600237 SHA256 b267cea49bf72790843e6b08e26c10a6954d7736a8b93deed1e632772f4f5fff SHA512 deb83c3417ac60bd5d4c6ac1cadf93d6a34a55ca58365b54bb0c3a8230ba6a7f13e0257515dac0170cc4ab46b558519c86e6c01f7fa49550162feed0b0ea2e89 WHIRLPOOL e6843593fbe4937ffcf600be9cb3dee78e14cbeb4c411a4b64076b1194653cbcb9d4bc6cbd52ad77ac9c6b14d4dd2cdafa4364bfe6924b55896844042aa4d9cd
diff --git a/sys-fabric/infinipath-psm/files/42-infinipath-psm.rules b/sys-fabric/infinipath-psm/files/42-infinipath-psm.rules
new file mode 100644
index 000000000000..8cc1339c16e9
--- /dev/null
+++ b/sys-fabric/infinipath-psm/files/42-infinipath-psm.rules
@@ -0,0 +1,2 @@
+KERNEL=="ipath", MODE="0666"
+KERNEL=="kcopy[0-6][0-9]", NAME="kcopy/%n", MODE="0666"
diff --git a/sys-fabric/infinipath-psm/files/infinipath-psm-include.patch b/sys-fabric/infinipath-psm/files/infinipath-psm-include.patch
new file mode 100644
index 000000000000..dd13ae0d1501
--- /dev/null
+++ b/sys-fabric/infinipath-psm/files/infinipath-psm-include.patch
@@ -0,0 +1,10 @@
+--- ./ptl_ips/ips_proto_header.h.orig 2012-01-20 15:49:17.000000000 +0400
++++ ./ptl_ips/ips_proto_header.h 2012-01-20 15:49:24.000000000 +0400
+@@ -72,7 +72,6 @@
+ union {
+ struct {
+ __u16 mqhdr : 14; /* PSM matched queues */
+- __u16 dst_subcontext : 2; /* Destination subcontext */
+ };
+ struct { /* for PSM Active Messages */
+ __u16 amhdr_hidx : 8;
diff --git a/sys-fabric/infinipath-psm/infinipath-psm-3.0.1.ebuild b/sys-fabric/infinipath-psm/infinipath-psm-3.0.1.ebuild
new file mode 100644
index 000000000000..a5f3391afcd8
--- /dev/null
+++ b/sys-fabric/infinipath-psm/infinipath-psm-3.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+OFED_VER="3.5"
+OFED_RC="1"
+OFED_RC_VER="2"
+OFED_SUFFIX="115.1015_open"
+OFED_SNAPSHOT="1"
+OFED_SRC_SNAPSHOT="1"
+
+inherit openib udev
+
+DESCRIPTION="OpenIB userspace driver for the PathScale InfiniBand HCAs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="sys-fabric/libibverbs:${SLOT}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+block_other_ofed_versions
+
+src_prepare() {
+ sed -e 's:uname -p:uname -m:g' \
+ -e 's:-Werror::g' \
+ -i buildflags.mak || die
+ epatch "${FILESDIR}"/${PN}-include.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+ udev_dorules "${FILESDIR}"/42-infinipath-psm.rules
+}
diff --git a/sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild b/sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild
new file mode 100644
index 000000000000..205e3fe83fd1
--- /dev/null
+++ b/sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OFED_VER="3.12"
+OFED_RC="1"
+OFED_RC_VER="1"
+OFED_SUFFIX="2_ga8c3e3e_open"
+OFED_SNAPSHOT="1"
+OFED_SRC_SNAPSHOT="1"
+
+inherit openib udev
+
+DESCRIPTION="OpenIB userspace driver for the PathScale InfiniBand HCAs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="sys-fabric/libibverbs:${SLOT}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+block_other_ofed_versions
+
+src_prepare() {
+ sed -e 's:uname -p:uname -m:g' \
+ -e 's:-Werror::g' \
+ -i buildflags.mak || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+ udev_dorules "${FILESDIR}"/42-infinipath-psm.rules
+}
diff --git a/sys-fabric/infinipath-psm/metadata.xml b/sys-fabric/infinipath-psm/metadata.xml
new file mode 100644
index 000000000000..4a09d7ba8d61
--- /dev/null
+++ b/sys-fabric/infinipath-psm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+</maintainer>
+</pkgmetadata>