summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-28 22:15:59 -0700
committerMike Frysinger <vapier@gentoo.org>2017-02-28 22:40:54 -0700
commit725db1f955f1c10227fca8e31bf564576d04bc9c (patch)
tree973468a958309bcad280367b4d01bc988c265341 /sys-fabric
parentopenib.eclass: switch HOMEPAGE to https (diff)
downloadgentoo-725db1f955f1c10227fca8e31bf564576d04bc9c.tar.gz
gentoo-725db1f955f1c10227fca8e31bf564576d04bc9c.tar.bz2
gentoo-725db1f955f1c10227fca8e31bf564576d04bc9c.zip
sys-fabric/libibverbs: add static-libs & multilib support
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/libibverbs/libibverbs-1.1.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fabric/libibverbs/libibverbs-1.1.7-r1.ebuild b/sys-fabric/libibverbs/libibverbs-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..3ed1e160e750
--- /dev/null
+++ b/sys-fabric/libibverbs/libibverbs-1.1.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+OFED_VER="3.12"
+OFED_RC="1"
+OFED_RC_VER="1"
+OFED_SUFFIX="1.gcbf2a35"
+
+inherit openib multilib-minimal
+
+DESCRIPTION="A library allowing programs to use InfiniBand 'verbs' for direct access to IB hardware"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !sys-fabric/openib-userspace"
+block_other_ofed_versions
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ use static-libs || find "${ED}/usr" -name '*.la' -delete
+}