summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-10 16:19:44 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-10 16:20:33 +0200
commit3615e8279553b70c7f24177db1f5a6ec10d31a94 (patch)
tree28fb4bcb5fac6ccd500dc283023ec13dc1effcff /sys-firmware
parentdev-util/uftrace: version bump to 0.11 (diff)
downloadgentoo-3615e8279553b70c7f24177db1f5a6ec10d31a94.tar.gz
gentoo-3615e8279553b70c7f24177db1f5a6ec10d31a94.tar.bz2
gentoo-3615e8279553b70c7f24177db1f5a6ec10d31a94.zip
sys-firmware/sof-firmware: Version bump 1.9
Closes: https://bugs.gentoo.org/816297 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-1.9.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index 3de67a4258f4..ebd6ba3d958b 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -14,3 +14,4 @@ DIST sof-firmware-1.4.2-sof-imx8.ldc 60848 BLAKE2B a17be83147fa58eb71698e9d7306d
DIST sof-firmware-1.4.2-sof-imx8.ri 115472 BLAKE2B ffb9fabdb388354b409881489594c411cc3c0fcbabb05688585696ad7b15f4a54a3f2786df811217b81cff210088e7e67ef1ae5e54c3e4e7827c69aa32ca5f87 SHA512 86e267cdd8fe835bdab7e082f0e9c527e8283757759c70069af52d4e23440439565380b10011fb746afed13a3fb2f1aadcaf54e45740b08b40a1f5455b57e05b
DIST sof-firmware-1.5.1.tar.gz 1611811 BLAKE2B 7408ba12f1375cb3d6c20e1654be225e8ab11e8b1471c54bd0a498ed1fad11954c57f68a7e483223117c5469278507b1d05e077420a1f58efb2eb0d2b4e95078 SHA512 0e3273f681dc3c0ee075bfb10e689e7ae8d8c0604f9d849f5bd991793d272e06ce7664a0b5829a9b93993d0576683824ee0ac5f8d1efe0b94a705a3e7ae34903
DIST sof-firmware-1.6.1.tar.gz 3033953 BLAKE2B 0c33bd9a5d17c3b889219bf926d3619e3e448ff6b16e39b4caffe19e87c98d1227b303ebe80d185f93480ead29f37de39093f3e76f275df7836d3250ae47c566 SHA512 71acd34662ffd4d93f6111dfd046ed358184fdf24d0e118da43770aeee45bd15105b688bc5a569f2cb7941724ec822d2cfbab8a08e9caee1a77aa5763ac7b48e
+DIST sof-firmware-1.9.tar.gz 3470302 BLAKE2B 597467915a658beda5611177c550b51a15720dfde23f1a55ea91217e7e809ff5c6417c6cc449e5d4a1732ffc03f9f817407951410646c9431ec189e8b141f60e SHA512 aee733381edb2150f2132c296e9151b1d6a71246e204b15c2394587c528286f730ceaf02002e1e58ccea0deba5e4ae81cb7a03efb858ac954633b0cfaec81a22
diff --git a/sys-firmware/sof-firmware/sof-firmware-1.9.ebuild b/sys-firmware/sof-firmware/sof-firmware-1.9.ebuild
new file mode 100644
index 000000000000..73dbc489b0e4
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-1.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S=${WORKDIR}/sof-bin-v${PV}
+
+QA_PREBUILT="/usr/bin/sof-logger"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" v${PV} || die
+}