summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/arm-fdisk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/arm-fdisk')
-rw-r--r--sys-fs/arm-fdisk/Manifest3
-rw-r--r--sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild44
-rw-r--r--sys-fs/arm-fdisk/arm-fdisk-3.0.6.ebuild37
-rw-r--r--sys-fs/arm-fdisk/metadata.xml5
4 files changed, 89 insertions, 0 deletions
diff --git a/sys-fs/arm-fdisk/Manifest b/sys-fs/arm-fdisk/Manifest
new file mode 100644
index 000000000000..673f366c9ce4
--- /dev/null
+++ b/sys-fs/arm-fdisk/Manifest
@@ -0,0 +1,3 @@
+DIST acorn-fdisk_3.0.6-6.2.diff.gz 5580 SHA256 d84e6a8c05114b044cace9d7705d319cbe38c3878eaf0918b1965453d88254ad SHA512 076587945548f10fef92a93910aee670927a2de9b1b32fd1b4ab72b1cfc26440177745f09b62f9b903987e3802060f4e278e1647ee12b7e2f29a0fd7b36ff188 WHIRLPOOL 6424710566c0c76e6aebcc32f5a9f4251402fc198aa22cad236caa10bf111b3a2a4377b940e6f98035a7193ca7e4b6045ba558557ad2b5b02422c09cb68ffc60
+DIST acorn-fdisk_3.0.6-6.diff.gz 5457 SHA256 ded7560b48ca758bca36fad7d015ad5766cf7f6f84fd89be13ac443138884fec
+DIST arm-fdisk-3.0.6.tar.gz 62266 SHA256 d6254982717be92aaffa1b6a2690d4e8b258285f7596beb196a9d24ceacf3a05 SHA512 954c1112c8108da676a0c4223de3a7b0320a37286b0ed099f3000bf4777ebb483b0b62eb0a5dd480f775c503020e7d9ed6ef737ef7bbc5bce858ae68aa471a3f WHIRLPOOL 3f26a40aa9823bdd87c163cc09d13e99679379238b233f32fe04b8235c4f42ce5d105d05a7a68561900c41b4990d177e69e0e694c5a8598a8e1d19e3745e78d9
diff --git a/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild b/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
new file mode 100644
index 000000000000..d76ae0587f31
--- /dev/null
+++ b/sys-fs/arm-fdisk/arm-fdisk-3.0.6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DEB_VER=6.2
+DESCRIPTION="edit disk partitions on Acorn machines"
+HOMEPAGE="http://www.arm.linux.org.uk/"
+SRC_URI="ftp://ftp.arm.linux.org.uk/pub/armlinux/source/other/${P}.tar.gz
+ mirror://debian/pool/main/a/acorn-fdisk/acorn-fdisk_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc s390 sh sparc x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/acorn-fdisk_${PV}-${DEB_VER}.diff
+
+ find "${S}" -name Makefile -print0 | xargs -0 \
+ sed -i \
+ -e "s:-O2 -Wall\( -g\)\?::" \
+ -e "/^CFLAGS/s:=:+=:" \
+ -e "/^LDFLAGS/s:=:+=:" \
+ -e '/^STRIP/s:strip:true:'
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" || die
+}
+
+src_install() {
+ into /
+ newsbin fdisk ${PN} || die "sbin failed"
+ dosym ${PN} /sbin/acorn-fdisk
+ dodoc ChangeLog README debian/changelog
+}
diff --git a/sys-fs/arm-fdisk/arm-fdisk-3.0.6.ebuild b/sys-fs/arm-fdisk/arm-fdisk-3.0.6.ebuild
new file mode 100644
index 000000000000..4b245ff19584
--- /dev/null
+++ b/sys-fs/arm-fdisk/arm-fdisk-3.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DEB_VER=6
+DESCRIPTION="edit disk partitions on Acorn machines"
+HOMEPAGE="http://www.arm.linux.org.uk/"
+SRC_URI="ftp://ftp.arm.linux.org.uk/pub/armlinux/source/other/${P}.tar.gz
+ mirror://debian/pool/main/a/acorn-fdisk/acorn-fdisk_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc s390 sh sparc x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/acorn-fdisk_${PV}-${DEB_VER}.diff
+
+ find "${S}" -name Makefile -print0 | xargs -0 \
+ sed -i \
+ -e "s:-O2 -Wall\( -g\)\?::" \
+ -e "/^CFLAGS/s:=:+=:" \
+ -e '/^STRIP/s:strip:true:'
+}
+
+src_install() {
+ into /
+ newsbin fdisk ${PN} || die "sbin failed"
+ dosym ${PN} /sbin/acorn-fdisk
+ dodoc ChangeLog README debian/changelog
+}
diff --git a/sys-fs/arm-fdisk/metadata.xml b/sys-fs/arm-fdisk/metadata.xml
new file mode 100644
index 000000000000..5454528f2093
--- /dev/null
+++ b/sys-fs/arm-fdisk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>arm</herd>
+</pkgmetadata>