summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-11-25 21:07:53 +0100
committerJeroen Roovers <jer@gentoo.org>2018-11-25 21:08:15 +0100
commit51ea732868abe708e2fb20bfe4f6190e065847d6 (patch)
tree2d49c8d500f2bccf12a745b5823a5dc3a1145548 /sys-fs/mac-fdisk
parentmedia-gfx/gimp: Fix call to ./configure (diff)
downloadgentoo-51ea732868abe708e2fb20bfe4f6190e065847d6.tar.gz
gentoo-51ea732868abe708e2fb20bfe4f6190e065847d6.tar.bz2
gentoo-51ea732868abe708e2fb20bfe4f6190e065847d6.zip
sys-fs/mac-fdisk: Define lseek64 properly
Bug: https://bugs.gentoo.org/671860 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-fs/mac-fdisk')
-rw-r--r--sys-fs/mac-fdisk/files/mac-fdisk-0.1_p18-lseek64.patch43
-rw-r--r--sys-fs/mac-fdisk/mac-fdisk-0.1_p18.ebuild9
2 files changed, 48 insertions, 4 deletions
diff --git a/sys-fs/mac-fdisk/files/mac-fdisk-0.1_p18-lseek64.patch b/sys-fs/mac-fdisk/files/mac-fdisk-0.1_p18-lseek64.patch
new file mode 100644
index 000000000000..d075d4760b81
--- /dev/null
+++ b/sys-fs/mac-fdisk/files/mac-fdisk-0.1_p18-lseek64.patch
@@ -0,0 +1,43 @@
+--- a/fdisk.c
++++ b/fdisk.c
+@@ -59,6 +59,10 @@
+ */
+
+
++#ifndef _LARGEFILE64_SOURCE
++#define _LARGEFILE64_SOURCE
++#endif
++#include <sys/types.h>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+--- a/fdisklabel.c
++++ b/fdisklabel.c
+@@ -35,6 +35,9 @@
+ SUCH DAMAGE.
+ */
+
++#ifndef _LARGEFILE64_SOURCE
++#define _LARGEFILE64_SOURCE
++#endif
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <stdio.h>
+--- a/io.c
++++ b/io.c
+@@ -25,6 +25,7 @@
+ * WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+
++#define _LARGEFILE64_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <fcntl.h>
+@@ -37,6 +38,7 @@
+ #endif
+ #endif
+ #include <linux/unistd.h>
++#include <sys/types.h>
+ #include <unistd.h>
+ #include <string.h>
+ #include <stdarg.h>
diff --git a/sys-fs/mac-fdisk/mac-fdisk-0.1_p18.ebuild b/sys-fs/mac-fdisk/mac-fdisk-0.1_p18.ebuild
index 4860ff66c37e..195bc8335867 100644
--- a/sys-fs/mac-fdisk/mac-fdisk-0.1_p18.ebuild
+++ b/sys-fs/mac-fdisk/mac-fdisk-0.1_p18.ebuild
@@ -20,15 +20,16 @@ PATCHES=(
"${WORKDIR}"/${PN}_${PV/_p*}-${PV/*_p}.diff
"${FILESDIR}"/largerthan2gb.patch
"${FILESDIR}"/${PN}-0.1-headers.patch
- ### Patch for bug #142737
+ # Patch for bug #142737
"${FILESDIR}"/${PN}-0.1_p16-ppc64.patch
### Patch for building on amd64
"${FILESDIR}"/${PN}-amd64.patch
- ### Patch for large (>550GB disks)
- ### Note that >=2TB disks may not work due to limitations of the Mac
- ### Partition Table structure, this needs to be investigated
+ # Patch for large (>550GB disks)
+ # Note that >=2TB disks may not work due to limitations of the Mac
+ # Partition Table structure, this needs to be investigated
"${FILESDIR}"/big_pt.patch
"${FILESDIR}"/${PN}-0.1_p16-ppc-inline.patch
+ "${FILESDIR}"/${PN}-0.1_p18-lseek64.patch
)
src_compile() {