summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-24 18:09:34 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-24 18:09:34 +0100
commitd82977346f4dfe0084ef74037fef2e38a3e130c6 (patch)
treeb6e69bbd786b4d17b6910f1c261020983bc866d9 /sys-fs
parentnet-dns/libidn2: amd64 stable wrt bug #674126 (diff)
downloadgentoo-d82977346f4dfe0084ef74037fef2e38a3e130c6.tar.gz
gentoo-d82977346f4dfe0084ef74037fef2e38a3e130c6.tar.bz2
gentoo-d82977346f4dfe0084ef74037fef2e38a3e130c6.zip
sys-fs/squashfs-tools: Also remove newly-added vulnerable ebuilds
Fixes: d4600db3d6bf1b83fe97517caec6c8f57d150db7 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-3.2-makedev.patch20
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-3.4-makedev.patch20
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild42
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.4-r1.ebuild42
4 files changed, 0 insertions, 124 deletions
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-3.2-makedev.patch b/sys-fs/squashfs-tools/files/squashfs-tools-3.2-makedev.patch
deleted file mode 100644
index c55d905dae18..000000000000
--- a/sys-fs/squashfs-tools/files/squashfs-tools-3.2-makedev.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/unsquashfs.c
-+++ b/unsquashfs.c
-@@ -34,6 +34,7 @@
- #include <zlib.h>
- #include <sys/mman.h>
- #include <utime.h>
-+#include <sys/sysmacros.h> /* makedev */
-
- #ifndef linux
- #define __BYTE_ORDER BYTE_ORDER
---- a/mksquashfs.c
-+++ b/mksquashfs.c
-@@ -44,6 +44,7 @@
- #include <sys/mman.h>
- #include <pthread.h>
- #include <math.h>
-+#include <sys/sysmacros.h> /* makedev */
-
- #ifndef linux
- #define __BYTE_ORDER BYTE_ORDER
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-3.4-makedev.patch b/sys-fs/squashfs-tools/files/squashfs-tools-3.4-makedev.patch
deleted file mode 100644
index da9d6bed456f..000000000000
--- a/sys-fs/squashfs-tools/files/squashfs-tools-3.4-makedev.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/mksquashfs.c
-+++ b/mksquashfs.c
-@@ -47,6 +47,7 @@
- #include <math.h>
- #include <regex.h>
- #include <fnmatch.h>
-+#include <sys/sysmacros.h> /* makedev */
-
- #ifndef linux
- #define __BYTE_ORDER BYTE_ORDER
---- a/unsquashfs.c
-+++ b/unsquashfs.c
-@@ -47,6 +47,7 @@
- #include <math.h>
- #include <sys/ioctl.h>
- #include <sys/time.h>
-+#include <sys/sysmacros.h> /* makedev */
-
- #ifndef linux
- #define __BYTE_ORDER BYTE_ORDER
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild
deleted file mode 100644
index 969a1b0ad8d3..000000000000
--- a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs
-
-MY_PV=${PV/_p/-r}
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.0" # squashfs filesystem version
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}"
-S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-PATCHES=(
- "${FILESDIR}"/${PN}-3.2-makedev.patch
-)
-
-src_prepare() {
- default
- sed -i \
- -e 's:-O2:$(CFLAGS):' \
- -e '/-lz/s:$: $(LDFLAGS):' \
- Makefile || die
-
- echo "struct dir_info; `grep '^int dir_scan2' mksquashfs.c`;" >> global.h
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- newbin mksquashfs mksquashfs-${SLOT}
- newbin unsquashfs unsquashfs-${SLOT}
- cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.2
-}
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.4-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.4-r1.ebuild
deleted file mode 100644
index 4b252ea04382..000000000000
--- a/sys-fs/squashfs-tools/squashfs-tools-3.4-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs
-
-MY_PV=${PV/_p/-r}
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.1" # squashfs filesystem version
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PN}-3.4-makedev.patch
-)
-S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
-
-src_prepare() {
- default
- sed -i \
- -e 's:-O2:$(CFLAGS):' \
- -e '/-lz/s:$: $(LDFLAGS):' \
- Makefile || die
-
- sed -i -e 's:get_nprocs():sysconf(_SC_NPROCESSORS_ONLN):' *.c
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- newbin mksquashfs mksquashfs-${SLOT}
- newbin unsquashfs unsquashfs-${SLOT}
- cd ..
- dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README
-}